summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-10-29 13:27:29 -0600
committerMark Wagie2021-10-29 13:27:29 -0600
commit8143ab81c98862fae997653a5afdbcbc02128de2 (patch)
tree1d6a1214362102c82bea9888c657b26a0fc7863a
parenta4ca924495ffe2cc5bf55e728d85696fc6338776 (diff)
downloadaur-8143ab81c98862fae997653a5afdbcbc02128de2.tar.gz
no untracked files
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD19
-rw-r--r--gps3.install8
3 files changed, 11 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b853e85daa28..42901ca9639f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = python-gps3
pkgdesc = Python GPSD interface
pkgver = 0.33.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/wadda/gps3
- install = gps3.install
arch = any
license = MIT
makedepends = python-pip
@@ -14,4 +13,3 @@ pkgbase = python-gps3
sha256sums = 79b976c5c314ca8828c95deb8a2c9cc28f1c93b0c74f4e6dd1dbe0ff8b972288
pkgname = python-gps3
-
diff --git a/PKGBUILD b/PKGBUILD
index 51bdd3421508..8d903399b694 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,27 @@
pkgname=python-gps3
_name=${pkgname#python-}
pkgver=0.33.3
-pkgrel=1
+pkgrel=2
pkgdesc="Python GPSD interface"
arch=('any')
url="https://github.com/wadda/gps3"
license=('MIT')
depends=('python')
makedepends=('python-pip')
-install="$_name.install"
source=("https://files.pythonhosted.org/packages/20/c1/9548cb5388a85e31557d1f1f66e2ad0b269d8aeb982f34f72f83d9bdbaeb/$_name-$pkgver-py2.py3-none-any.whl"
"https://github.com/wadda/gps3/raw/master/LICENSE")
sha256sums=('9c7ef9fa334ae6d4157fa63abe6df334d4f0878dbb628d10cb4c5f304eb22978'
'79b976c5c314ca8828c95deb8a2c9cc28f1c93b0c74f4e6dd1dbe0ff8b972288')
-
package() {
- PIP_CONFIG_FILE=/dev/null pip install \
- --isolated \
- --root="$pkgdir" \
- --ignore-installed \
- --no-deps *.whl
+ PIP_CONFIG_FILE=/dev/null pip install \
+ --isolated \
+ --root="$pkgdir" \
+ --ignore-installed \
+ --no-deps *.whl
+
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ python -O -m compileall "$pkgdir$site_packages/$_name"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}
diff --git a/gps3.install b/gps3.install
deleted file mode 100644
index 4bbe29ded5ed..000000000000
--- a/gps3.install
+++ /dev/null
@@ -1,8 +0,0 @@
-post_install() {
- local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
- python -O -m compileall "$site_packages/gps3"
-}
-
-post_upgrade() {
- post_install
-}