summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesper Jensen2018-01-30 18:02:14 +0100
committerJesper Jensen2018-01-30 18:05:14 +0100
commit48d81bdf2c871d301ae2cf7118de283f0778797f (patch)
treed407e53fc04c143d71346136cf8883cb80fe5253
downloadaur-48d81bdf2c871d301ae2cf7118de283f0778797f.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a5d2ec8f6a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-gpsoauth
+ pkgdesc = A python client library for Google Play Services OAuth.
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://github.com/simon-weber/gpsoauth
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-requests
+ depends = python-pycryptodomex
+ source = https://files.pythonhosted.org/packages/source/g/gpsoauth/gpsoauth-0.4.1.tar.gz
+ md5sums = bdbdcb78b8f14670eac5c47d073e6a05
+
+pkgname = python-gpsoauth
+ depends = python
+ depends = python-requests
+ depends = python-pycryptodomex
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2d5111b65db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgbase=('python-gpsoauth')
+pkgname=('python-gpsoauth')
+_module='gpsoauth'
+pkgver='0.4.1'
+pkgrel=1
+pkgdesc="A python client library for Google Play Services OAuth."
+url="https://github.com/simon-weber/gpsoauth"
+depends=('python' 'python-requests' 'python-pycryptodomex')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/g/gpsoauth/gpsoauth-${pkgver}.tar.gz")
+md5sums=('bdbdcb78b8f14670eac5c47d073e6a05')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}