summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-03-11 00:19:19 +0000
committerGrey Christoforo2019-03-11 00:19:19 +0000
commit25441ec849c888255b9b3805f6ff65fc130dd407 (patch)
tree3979da197a94c621f34155a36f6b7ec738ac8f62
downloadaur-25441ec849c888255b9b3805f6ff65fc130dd407.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD27
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e449d68ab448
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-gpustat
+ pkgdesc = A simple command-line utility for querying and monitoring GPU status
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://github.com/wookayin/gpustat
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-six
+ depends = nvidia
+ source = https://github.com/wookayin/gpustat/archive/v0.5.0.tar.gz
+ sha256sums = 1b6cac5f3584028504f3cb8738798dfa4989f74084617ae8fce509c5b426abc7
+
+pkgname = python-gpustat
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72a3ed3fe6e0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0461cf33d503
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+
+pkgname=python-gpustat
+_pkgname=gpustat
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="A simple command-line utility for querying and monitoring GPU status"
+arch=('any')
+url=https://github.com/wookayin/gpustat
+license=('MIT')
+depends=('python' 'python-six' 'nvidia')
+makedepends=('python-setuptools')
+source=("https://github.com/wookayin/${_pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('1b6cac5f3584028504f3cb8738798dfa4989f74084617ae8fce509c5b426abc7')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+
+package(){
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:ts=2:sw=2:et: