summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorØystein Sture2023-12-22 13:25:59 +0100
committerØystein Sture2023-12-22 13:25:59 +0100
commit656fb92c8775193ae68935f808e3c8b402b1dcf9 (patch)
tree9e8a794f780ee98b764ea00373ed26d16d765bf6
parentd1c7d44359d15bd0bc9a7680eaaa8a50a6f23c31 (diff)
downloadaur-python-gpy.tar.gz
v1.13.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dab63cae21da..9ad5f873a918 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = python-gpy
pkgdesc = Gaussian processes framework in python
- pkgver = 1.10.0
- pkgrel = 2
+ pkgver = 1.13.0
+ pkgrel = 1
url = https://github.com/SheffieldML/GPy
arch = any
license = BSD
makedepends = python-setuptools
makedepends = python-numpy
makedepends = cython
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
depends = python-numpy
depends = python-scipy
@@ -23,7 +26,7 @@ pkgbase = python-gpy
optdepends = python-jupyter_client
optdepends = jupyter-notebook
optdepends = python-mpi4py
- source = https://files.pythonhosted.org/packages/source/G/GPy/GPy-1.10.0.tar.gz
- sha256sums = a2b793ef8d0ac71739e7ba1c203bc8a5afa191058b42caa617e0e29aa52aa6fb
+ source = https://github.com/SheffieldML/GPy/archive/refs/tags/v.1.13.0.tar.gz
+ sha256sums = eceb9559b1ec565c767aa422ac896a5a3422da7dda0b42629e69311212766920
pkgname = python-gpy
diff --git a/PKGBUILD b/PKGBUILD
index 6078c582db3c..4e30586233e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,32 +3,32 @@
pkgname=python-gpy
_name=GPy
-pkgver=1.10.0
-pkgrel=2
+pkgver=1.13.0
+pkgrel=1
pkgdesc="Gaussian processes framework in python"
arch=("any")
license=("BSD")
url="https://github.com/SheffieldML/GPy"
depends=('python' 'python-numpy' 'python-scipy' 'python-six' 'python-paramz' 'python-matplotlib' 'python-climin-git')
optdepends=('python-plotly' 'ipython' 'python-sphinx' 'python-ipykernel' 'python-ipywidgets' 'python-jupyter_client' 'jupyter-notebook' 'python-mpi4py')
-makedepends=('python-setuptools' 'python-numpy' 'cython')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('a2b793ef8d0ac71739e7ba1c203bc8a5afa191058b42caa617e0e29aa52aa6fb')
+makedepends=('python-setuptools' 'python-numpy' 'cython' 'python-build' 'python-installer' 'python-wheel')
+source=("https://github.com/SheffieldML/GPy/archive/refs/tags/v.${pkgver}.tar.gz")
+sha256sums=('eceb9559b1ec565c767aa422ac896a5a3422da7dda0b42629e69311212766920')
prepare() {
- cd "GPy-${pkgver}"
+ cd "GPy-v.${pkgver}"
# Forcibly update cython for python 3.7 (https://github.com/SheffieldML/GPy/issues/649)
find . -name '*.pyx' -exec cython -v -3 {} \;
}
build() {
- cd "GPy-${pkgver}"
- python setup.py build
+ cd "GPy-v.${pkgver}"
+ python -m build --wheel --no-isolation
}
package() {
- cd "GPy-${pkgver}"
- python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ cd "GPy-v.${pkgver}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python-gpy/LICENSE"
}