summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroysstu2018-07-14 15:33:30 +0200
committeroysstu2018-07-14 15:33:30 +0200
commit2fdc6761725b76366d4a8c4a8b13127a65b729d7 (patch)
treedbc19bdd15e0627f7496aecb862fab771800d9c1
downloadaur-2fdc6761725b76366d4a8c4a8b13127a65b729d7.tar.gz
v1.9.2
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD26
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df8697f76a87
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = python-gpy
+ pkgdesc = Gaussian processes framework in python
+ pkgver = 1.9.2
+ pkgrel = 1
+ url = https://github.com/SheffieldML/GPy
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ makedepends = python-numpy
+ depends = python
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-six
+ depends = python-paramz
+ depends = python-matplotlib
+ optdepends = python-plotly
+ optdepends = ipython
+ optdepends = python-sphinx
+ optdepends = python-ipykernel
+ optdepends = python-ipywidgets
+ optdepends = python-jupyter_client
+ optdepends = jupyter-notebook
+ optdepends = python-mpi4py
+ source = https://github.com/SheffieldML/GPy/archive/v1.9.2.tar.gz
+ sha512sums = 50dc3627a05b9fc2fbc61204cf492e89d5c067da7aca3e738c52cc3c06652aa825e27e66b0a14a2e67e074cd19a75ab564449a762f1de1ba27a02fc986432403
+
+pkgname = python-gpy
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..202e206f7aab
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.pkg.tar.xz
+*.tar.gz
+/pkg/
+/src/
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..595fadbded13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Oystein Sture <oysstu@gmail.com>
+# Contributor:
+
+pkgname=python-gpy
+pkgver=1.9.2
+pkgrel=1
+pkgdesc="Gaussian processes framework in python"
+arch=("any")
+license=("BSD")
+url="https://github.com/SheffieldML/GPy"
+depends=('python' 'python-numpy' 'python-scipy' 'python-six' 'python-paramz' 'python-matplotlib')
+optdepends=('python-plotly' 'ipython' 'python-sphinx' 'python-ipykernel' 'python-ipywidgets' 'python-jupyter_client' 'jupyter-notebook' 'python-mpi4py')
+makedepends=('python-setuptools' 'python-numpy')
+source=("https://github.com/SheffieldML/GPy/archive/v${pkgver}.tar.gz")
+sha512sums=("50dc3627a05b9fc2fbc61204cf492e89d5c067da7aca3e738c52cc3c06652aa825e27e66b0a14a2e67e074cd19a75ab564449a762f1de1ba27a02fc986432403")
+
+build() {
+ cd "GPy-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "GPy-${pkgver}"
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python-gpy/LICENSE"
+}