summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2022-08-31 12:30:59 -0400
committeracxz2022-08-31 12:30:59 -0400
commit4ca2a5c087648308af7494c6fbaa4ae670a3a77b (patch)
tree692393f103e717d49170a2ed6fef7337b824464e
parentc130d09b220024f22b3bf4464b6148f6cf35ad25 (diff)
downloadaur-4ca2a5c087648308af7494c6fbaa4ae670a3a77b.tar.gz
upgpkg: python-gpytorch 1.9.0-1
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD31
2 files changed, 17 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6496cdcb62b4..43b0d94d50a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,22 @@
pkgbase = python-gpytorch
pkgdesc = A highly efficient and modular implementation of GPs, with GPU acceleration. Implemented in PyTorch.
- pkgver = 1.8.1
+ pkgver = 1.9.0
pkgrel = 1
url = https://gpytorch.ai
arch = x86_64
license = MIT
+ makedepends = git
makedepends = python
makedepends = python-build
makedepends = python-installer
makedepends = python-wheel
makedepends = python-setuptools
+ makedepends = python-setuptools-scm
depends = python
- depends = python-pytorch
- depends = python-numpy
depends = python-scikit-learn
- depends = python-scipy
- optdepends = python-black: for [dev] module
- optdepends = twine: for [dev] module
- optdepends = python-pre-commit: for [dev] module
- optdepends = ipython: for [docs/examples] module
- optdepends = python-ipykernel: for [docs] module
- optdepends = python-sphinx: for [docs] module
- optdepends = python-sphinx_rtd_theme: for [docs] module
- optdepends = python-nbsphinx: for [docs] module
- optdepends = m2r: for [docs] module
+ depends = python-linear-operator
+ depends = python-pytorch
+ optdepends = ipython: for [examples] module
optdepends = jupyter: for [examples] module
optdepends = python-matplotlib: for [examples] module
optdepends = python-scipy: for [examples] module
@@ -31,11 +24,7 @@ pkgbase = python-gpytorch
optdepends = python-tqdm: for [examples] module
optdepends = python-pyro-ppl: for [pyro] module
optdepends = python-pykeops: for [keops] module
- optdepends = python-flake8: for [test] module
- optdepends = python-flake8-print: for [test] module
- optdepends = python-pytest: for [test] module
- optdepends = python-nbval: for [test] module
- source = python-gpytorch-1.8.1::https://github.com/cornellius-gp/gpytorch/archive/v1.8.1.tar.gz
- sha256sums = be1bcbc2d8db835e145d710ba7520ab0c5907fe0e28a08c9d7ac76ae8e4f1f7c
+ source = python-gpytorch-1.9.0::git+https://github.com/cornellius-gp/gpytorch.git#tag=v1.9.0
+ sha256sums = SKIP
pkgname = python-gpytorch
diff --git a/PKGBUILD b/PKGBUILD
index 679879c28003..c286cd76d3c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,18 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=python-gpytorch
-pkgver=1.8.1
+pkgver=1.9.0
pkgrel=1
pkgdesc='A highly efficient and modular implementation of GPs, with GPU
acceleration. Implemented in PyTorch.'
arch=('x86_64')
url='https://gpytorch.ai'
license=('MIT')
-depends=('python' 'python-pytorch' 'python-numpy' 'python-scikit-learn' 'python-scipy')
-makedepends=('python' 'python-build' 'python-installer' 'python-wheel' 'python-setuptools')
+depends=('python' 'python-scikit-learn' 'python-linear-operator' 'python-pytorch')
+makedepends=('git' 'python' 'python-build' 'python-installer' 'python-wheel'
+ 'python-setuptools' 'python-setuptools-scm')
optdepends=(
- 'python-black: for [dev] module'
- 'twine: for [dev] module'
- 'python-pre-commit: for [dev] module'
- 'ipython: for [docs/examples] module'
- 'python-ipykernel: for [docs] module'
- 'python-sphinx: for [docs] module'
- 'python-sphinx_rtd_theme: for [docs] module'
- 'python-nbsphinx: for [docs] module'
- 'm2r: for [docs] module'
+ 'ipython: for [examples] module'
'jupyter: for [examples] module'
'python-matplotlib: for [examples] module'
'python-scipy: for [examples] module'
@@ -27,22 +20,16 @@ optdepends=(
'python-tqdm: for [examples] module'
'python-pyro-ppl: for [pyro] module'
'python-pykeops: for [keops] module'
- 'python-flake8: for [test] module'
- 'python-flake8-print: for [test] module'
- 'python-pytest: for [test] module'
- 'python-nbval: for [test] module'
)
-source=("$pkgname-$pkgver::https://github.com/cornellius-gp/gpytorch/archive/v$pkgver.tar.gz")
-sha256sums=('be1bcbc2d8db835e145d710ba7520ab0c5907fe0e28a08c9d7ac76ae8e4f1f7c')
-
-_pkgname=gpytorch
+source=("$pkgname-$pkgver::git+https://github.com/cornellius-gp/gpytorch.git#tag=v$pkgver")
+sha256sums=('SKIP')
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
python -m build --wheel --no-isolation
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
python -m installer --destdir="$pkgdir" dist/*.whl
}