summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2022-06-27 22:25:08 -0400
committeracxz2022-06-27 22:25:08 -0400
commit72510384028b34a29007f67646b680410ba59962 (patch)
tree0bd49937af33036f534a8522057c360af9e5f728
parentdc306f01d1b37c66308c787aa305337b6c78dc11 (diff)
downloadaur-72510384028b34a29007f67646b680410ba59962.tar.gz
upgpkg: python-gpytorch 1.7.0-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9dd6dd754e1c..c290febe4e7b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,18 @@
pkgbase = python-gpytorch
pkgdesc = A highly efficient and modular implementation of GPs, with GPU acceleration. Implemented in PyTorch.
- pkgver = 1.6.0
+ pkgver = 1.7.0
pkgrel = 1
url = https://gpytorch.ai
arch = x86_64
license = MIT
makedepends = python
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
makedepends = python-setuptools
depends = python
depends = python-pytorch
+ depends = python-numpy
depends = python-scikit-learn
depends = python-scipy
optdepends = python-black: for [dev] module
@@ -31,7 +35,7 @@ pkgbase = python-gpytorch
optdepends = python-flake8-print: for [test] module
optdepends = python-pytest: for [test] module
optdepends = python-nbval: for [test] module
- source = python-gpytorch-1.6.0::https://github.com/cornellius-gp/gpytorch/archive/v1.6.0.tar.gz
- sha256sums = 732be00f7b490a2b4e15728d7f1357209979ef500c3d7e6c3b09a603c0d42020
+ source = python-gpytorch-1.7.0::https://github.com/cornellius-gp/gpytorch/archive/v1.7.0.tar.gz
+ sha256sums = 69eaedb0dd0881b6804bd4ad3200c36c6db0a7859dd82c70d5ef27e501dc8bd5
pkgname = python-gpytorch
diff --git a/PKGBUILD b/PKGBUILD
index 87d102da1c50..258dd4b95a52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=python-gpytorch
-pkgver=1.6.0
+pkgver=1.7.0
pkgrel=1
pkgdesc='A highly efficient and modular implementation of GPs, with GPU
acceleration. Implemented in PyTorch.'
arch=('x86_64')
url='https://gpytorch.ai'
license=('MIT')
-depends=('python' 'python-pytorch' 'python-scikit-learn' 'python-scipy')
-makedepends=('python' 'python-setuptools')
+depends=('python' 'python-pytorch' 'python-numpy' 'python-scikit-learn' 'python-scipy')
+makedepends=('python' 'python-build' 'python-installer' 'python-wheel' 'python-setuptools')
optdepends=(
'python-black: for [dev] module'
'twine: for [dev] module'
@@ -33,16 +33,16 @@ optdepends=(
'python-nbval: for [test] module'
)
source=("$pkgname-$pkgver::https://github.com/cornellius-gp/gpytorch/archive/v$pkgver.tar.gz")
-sha256sums=('732be00f7b490a2b4e15728d7f1357209979ef500c3d7e6c3b09a603c0d42020')
+sha256sums=('69eaedb0dd0881b6804bd4ad3200c36c6db0a7859dd82c70d5ef27e501dc8bd5')
_pkgname=gpytorch
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- python setup.py install --root="$pkgdir"/ --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}