summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-05-13 16:23:11 -0400
committeracxz2020-05-13 16:23:11 -0400
commit8ec25b3e846f1840e630e637a6eec3dcd4c8f910 (patch)
treebf158875cabc2abf689bd43d585d7085bd230815
parent257bcfb71fd9849b247ca17ecdad44894066585b (diff)
downloadaur-8ec25b3e846f1840e630e637a6eec3dcd4c8f910.tar.gz
add opt deps
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD25
2 files changed, 44 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f93b1ec2da91..eebd21f90c0a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-gpytorch
pkgdesc = A highly efficient and modular implementation of GPs, with GPU acceleration. Implemented in PyTorch.
pkgver = 1.1.1
- pkgrel = 1
+ pkgrel = 2
url = https://gpytorch.ai
arch = x86_64
license = MIT
@@ -9,6 +9,26 @@ pkgbase = python-gpytorch
makedepends = python-setuptools
depends = python
depends = python-pytorch
+ optdepends = python-black: for [dev] module
+ optdepends = twine: for [dev] module
+ optdepends = python-pre-commit: for [dev] module
+ optdepends = ipython: for [docs/examples] module
+ optdepends = python-ipykernel: for [docs] module
+ optdepends = python-sphinx: for [docs] module
+ optdepends = python-sphinx_rtd_theme: for [docs] module
+ optdepends = python-nbsphinx: for [docs] module
+ optdepends = m2r: for [docs] module
+ optdepends = jupyter: for [examples] module
+ optdepends = python-matplotlib: for [examples] module
+ optdepends = python-scipy: for [examples] module
+ optdepends = python-torchvision: for [examples] module
+ optdepends = python-tqdm: for [examples] module
+ optdepends = python-pyro-ppl: for [pyro] module
+ optdepends = python-pykeops: for [keops] module
+ optdepends = python-flake8: for [test] module
+ optdepends = python-flake8-print: for [test] module
+ optdepends = python-pytest: for [test] module
+ optdepends = python-nbval: for [test] module
source = python-gpytorch-1.1.1::https://github.com/cornellius-gp/gpytorch/archive/v1.1.1.tar.gz
sha256sums = 8ef20659e3a077554a3582554ee39e4bed3b95902dfd4cac693328c387e2899c
diff --git a/PKGBUILD b/PKGBUILD
index 68daa6a48659..0a7cbd8b0f47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,36 @@
pkgname=python-gpytorch
pkgver=1.1.1
-pkgrel=1
+pkgrel=2
pkgdesc='A highly efficient and modular implementation of GPs, with GPU
acceleration. Implemented in PyTorch.'
arch=('x86_64')
url='https://gpytorch.ai'
license=('MIT')
depends=('python' 'python-pytorch')
-optdepends=()
makedepends=('python' 'python-setuptools')
+optdepends=(
+ 'python-black: for [dev] module'
+ 'twine: for [dev] module'
+ 'python-pre-commit: for [dev] module'
+ 'ipython: for [docs/examples] module'
+ 'python-ipykernel: for [docs] module'
+ 'python-sphinx: for [docs] module'
+ 'python-sphinx_rtd_theme: for [docs] module'
+ 'python-nbsphinx: for [docs] module'
+ 'm2r: for [docs] module'
+ 'jupyter: for [examples] module'
+ 'python-matplotlib: for [examples] module'
+ 'python-scipy: for [examples] module'
+ 'python-torchvision: for [examples] module'
+ 'python-tqdm: for [examples] module'
+ 'python-pyro-ppl: for [pyro] module'
+ 'python-pykeops: for [keops] module'
+ 'python-flake8: for [test] module'
+ 'python-flake8-print: for [test] module'
+ 'python-pytest: for [test] module'
+ 'python-nbval: for [test] module'
+ )
source=("$pkgname-$pkgver::https://github.com/cornellius-gp/gpytorch/archive/v$pkgver.tar.gz")
sha256sums=('8ef20659e3a077554a3582554ee39e4bed3b95902dfd4cac693328c387e2899c')