summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2022-10-22 22:23:25 +0800
committerYour Name2022-10-22 22:23:25 +0800
commit858d04c579b33a33c7bbc6ff10b6896b75768c67 (patch)
treebc57dfbbd43857c575e6e4f4987ed4a4ab509843
parentebc685796ebbd377ac5387058c453386b20e80b2 (diff)
downloadaur-858d04c579b33a33c7bbc6ff10b6896b75768c67.tar.gz
pack python-gradio
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46b428791474..e366206e2a32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,6 +11,7 @@ pkgbase = python-gradio
makedepends = python-hatchling
makedepends = python-hatch-requirements-txt
makedepends = python-hatch-fancy-pypi-readme
+ makedepends = pnpm
depends = python-aiohttp
depends = python-h11
depends = python-fastapi
diff --git a/PKGBUILD b/PKGBUILD
index 3c2f570dcfcf..1e1b1dfdd43a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -33,10 +33,11 @@ depends=(
'python-linkify-it-py'
'python-mdit_py_plugins'
)
-makedepends=(python-build python-installer python-wheel python-hatchling python-hatch-requirements-txt python-hatch-fancy-pypi-readme)
+makedepends=(python-build python-installer python-wheel python-hatchling python-hatch-requirements-txt python-hatch-fancy-pypi-readme pnpm)
build() {
cd gradio-$pkgver
+ sh ./scripts/build_frontend.sh
python -m build --wheel --no-isolation
}