summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss2017-03-07 09:17:28 +0100
committerLuca Weiss2017-03-07 09:17:28 +0100
commita9e5c15532f87feac834b86038b250770c2ca16e (patch)
tree48c0649677ab6f53a48c45712dc501dcd46e44a5
downloadaur-a9e5c15532f87feac834b86038b250770c2ca16e.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d88027e5c209
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Tue Mar 7 08:17:10 UTC 2017
+pkgbase = python-grapefruit
+ pkgdesc = A module to manipulate color information easily.
+ pkgver = 0.1a4
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/grapefruit/
+ arch = any
+ license = GPL
+ depends = python
+ options = !emptydirs
+ source = https://files.pythonhosted.org/packages/source/g/grapefruit/grapefruit-0.1a4.tar.gz
+ sha512sums = 8f139b90319a282f529de416654da0b9ccc4e7d50f0f4acd2ff27b96fd1650b87f5091e91a3590fd5fe025ee4b0977174195f1e532470a80feb5c9dc73f5aad5
+
+pkgname = python-grapefruit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a8507ed68158
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Luca Weiss <luca (at) z3ntu (dot) xyz>
+
+_name=grapefruit
+pkgname=python-$_name
+pkgver=0.1a4
+pkgrel=1
+pkgdesc="A module to manipulate color information easily."
+arch=('any')
+url="https://pypi.python.org/pypi/$_name/"
+license=('GPL')
+depends=('python')
+options=(!emptydirs)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha512sums=('8f139b90319a282f529de416654da0b9ccc4e7d50f0f4acd2ff27b96fd1650b87f5091e91a3590fd5fe025ee4b0977174195f1e532470a80feb5c9dc73f5aad5')
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: