summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTiago de Paula Peixoto2023-08-18 15:08:28 +0200
committerTiago de Paula Peixoto2023-08-18 15:08:28 +0200
commitcac9ce9ab0e7d11a54efd6e3be344c4d6cb45a0f (patch)
tree850709b1d87b7d716520d8afb69f932b03d2653a
parent93659bb9a8b6b496e59783a64eb2d8674d332cec (diff)
downloadaur-python-graph-tool-git.tar.gz
Update dependencies and fixes
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a9a521746c8..0e7bb82cdcb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-graph-tool-git
pkgdesc = A Python module for manipulation and statistical analysis of graphs
- pkgver = 2.27.r7.g41bae98c
+ pkgver = 99
pkgrel = 1
url = https://graph-tool.skewed.de
arch = i686
@@ -9,11 +9,16 @@ pkgbase = python-graph-tool-git
makedepends = boost
makedepends = sparsehash
makedepends = autoconf-archive
- depends = cgal
- depends = cairomm
+ depends = boost-libs
+ depends = python
+ depends = expat
depends = python-scipy
depends = python-numpy
+ depends = cgal
+ depends = cairomm-1.16
depends = python-cairo
+ depends = python-zstandard
+ depends = python-gobject
optdepends = graphviz: graph layout
optdepends = python-matplotlib: graph drawing
provides = python-graph-tool
@@ -24,4 +29,3 @@ pkgbase = python-graph-tool-git
sha256sums = SKIP
pkgname = python-graph-tool-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 756bfb8b3ad6..206e706e0b5e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,14 @@
-# Maintainer: Aleksandar Trifunović <akstrfn at gmail dot com>
-# Contributor: Tiago de Paula Peixoto <tiago@skewed.de>
+# Maintainer: Tiago de Paula Peixoto <tiago@skewed.de>
_pkgname=python-graph-tool
pkgname=python-graph-tool-git
-pkgver=2.27.r7.g41bae98c
+pkgver=99
pkgrel=1
pkgdesc='A Python module for manipulation and statistical analysis of graphs'
arch=('i686' 'x86_64')
url='https://graph-tool.skewed.de'
license=(GPL3)
-depends=(cgal cairomm python-scipy python-numpy python-cairo)
+depends=(boost-libs python expat python-scipy python-numpy cgal cairomm-1.16 python-cairo python-zstandard python-gobject)
makedepends=(boost sparsehash autoconf-archive)
optdepends=('graphviz: graph layout'
'python-matplotlib: graph drawing')
@@ -28,6 +27,9 @@ pkgver() {
build() {
cd "$pkgname"
./autogen.sh
+ # disable assertions which lead to runtime performance degradation
+ CXXFLAGS=${CXXFLAGS/-Wp,-D_GLIBCXX_ASSERTIONS/}
+ export CXXFLAGS="$CXXFLAGS -O3 -march=native -flto=auto -fno-fat-lto-objects"
./configure --enable-openmp --prefix=/usr --docdir="/usr/share/doc/$_pkgname"
make -j 1 # most users will be surprised with the high memory usage required for parallel builds
}