summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArturo Penen2024-09-18 16:05:02 +0200
committerArturo Penen2024-09-18 16:05:02 +0200
commit44ab222e91b0e1c5a2899abb1c285dc056cd91be (patch)
tree9ed5227dad89fee7c422a4b90a4c66279601a468
downloadaur-44ab222e91b0e1c5a2899abb1c285dc056cd91be.tar.gz
chore: version 1.66.1
Signed-off-by: Arturo Penen <arturo.penen@diagroup.com>
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD30
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..282eff760cf0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = python-grpcio-status
+ pkgdesc = Status proto mapping for gRPC
+ pkgver = 1.66.1
+ pkgrel = 1
+ url = https://grpc.io
+ arch = any
+ license = Apache-2.0
+ makedepends = python-setuptools
+ makedepends = python-wheel
+ makedepends = python-installer
+ makedepends = python-build
+ depends = python
+ depends = python-google-api-core
+ depends = python-proto-plus
+ depends = python-protobuf
+ depends = python-google-auth
+ depends = python-grpcio
+ options = !emptydirs
+ source = https://files.pythonhosted.org/packages/source/g/grpcio_status/grpcio_status-1.66.1.tar.gz
+ sha256sums = b3f7d34ccc46d83fea5261eea3786174459f763c31f6e34f1d24eba6d515d024
+
+pkgname = python-grpcio-status
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3cd5ad0df10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Arturo Penen <apenen@gmail.com>
+
+_name=grpcio_status
+pkgname=python-grpcio-status
+pkgver=1.66.1
+pkgrel=1
+pkgdesc="Status proto mapping for gRPC"
+url=https://grpc.io
+arch=(any)
+license=(Apache-2.0)
+depends=(python python-google-api-core python-proto-plus python-protobuf
+ python-google-auth python-grpcio)
+makedepends=(python-setuptools python-wheel python-installer python-build)
+options=(!emptydirs)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('b3f7d34ccc46d83fea5261eea3786174459f763c31f6e34f1d24eba6d515d024')
+
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 README.rst "$pkgdir/usr/share/doc/$pkgname/README.rst"
+}
+
+# vim: set ts=2 sw=2 et:
+