summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s.2017-11-14 17:04:13 -0500
committerbrent s.2017-11-14 17:04:13 -0500
commit4d6137784491d29d4fe5223c8a1bf49798e70b6e (patch)
tree428a81fd6e1e66bf1af2ad31a22f8d2804eaed8c
downloadaur-4d6137784491d29d4fe5223c8a1bf49798e70b6e.tar.gz
initial commit; setting up .gitignores and skeleton PKGBUILD
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore18
-rw-r--r--PKGBUILD27
-rw-r--r--grpcio-tools-1.7.0.tar.gz.sig16
4 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..71ec562d8238
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by aurpkgs
+# Tue Nov 14 22:04:13 UTC 2017
+pkgbase = python-grpcio-tools
+ pkgdesc = Python protobuf generator for GRPC
+ pkgver = 1.7.0
+ pkgrel = 1
+ url = https://grpc.io/
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ source = https://pypi.python.org/packages/44/09/06843f65aa75d8d1852acc8983ea070a273f2005995a2fe316d142f6f2c3/grpcio-tools-1.7.0.tar.gz
+ source = grpcio-tools-1.7.0.tar.gz.sig
+ sha512sums = 9205f9804b13f01d2543e037496bcab1eb026d35daa0f3e3a3da87cfb561be5f61da09411757a82e08a21f77dcdc10694ea3aa1a4668c6689cdbc4223991e8d7
+ sha512sums = SKIP
+
+pkgname = python-grpcio-tools
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e16177da2907
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,18 @@
+*/
+.*.swp
+*.pkg.tar.xz
+src/
+pkg/
+*.tar
+*.tar.bz2
+*.tar.xz
+*.tar.gz
+*.tgz
+*.txz
+*.tbz
+*.tbz2
+*.zip
+*.run
+*.7z
+*.rar
+*.deb
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a45361d71a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: brent s. <bts[at]square-r00t[dot]net>
+validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
+# Bug reports can be filed at https://bugs.square-r00t.net/index.php?project=3
+# News updates for packages can be followed at https://devblog.square-r00t.net
+pkgname=python-grpcio-tools
+pkgver=1.7.0
+pkgrel=1
+pkgdesc="Python protobuf generator for GRPC"
+arch=( 'i686' 'x86_64' )
+url="https://grpc.io/"
+license=( 'APACHE' )
+_pkgname=python-grpcio-tools
+install=
+changelog=
+noextract=()
+source=("https://pypi.python.org/packages/44/09/06843f65aa75d8d1852acc8983ea070a273f2005995a2fe316d142f6f2c3/grpcio-tools-1.7.0.tar.gz"
+ "grpcio-tools-1.7.0.tar.gz.sig")
+sha512sums=('9205f9804b13f01d2543e037496bcab1eb026d35daa0f3e3a3da87cfb561be5f61da09411757a82e08a21f77dcdc10694ea3aa1a4668c6689cdbc4223991e8d7'
+ 'SKIP')
+build() {
+ cd "${srcdir}/${_pkgname}/src"
+ make prefix=${pkgdir}/usr
+}
+package() {
+ install -D -m755 ${srcdir}/${_pkgname}/src/${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
+ install -D -m644 ${srcdir}/${_pkgname}/docs/README.html.en ${pkgdir}/usr/share/doc/${_pkgname}/README.html
+}
diff --git a/grpcio-tools-1.7.0.tar.gz.sig b/grpcio-tools-1.7.0.tar.gz.sig
new file mode 100644
index 000000000000..ec0e5fe38a0e
--- /dev/null
+++ b/grpcio-tools-1.7.0.tar.gz.sig
@@ -0,0 +1,16 @@
+-----BEGIN PGP SIGNATURE-----
+
+iQIzBAABCgAdFiEEdIIx68vYCKFPXoXSjABML5NIH2sFAloLaFQACgkQjABML5NI
+H2uXhQ/9Exz064js7KpHPe4hJ1TwIwc+FY2Fef24SQnIyp6XKSGvpuY5xqJtYBmJ
+mDtQ7OxQiUp7+Cvf9h6QQ3jQmYPpQhLsMEMZAcnzPNHFpE+sG2I+HCLc4oufoz4L
+WAsZTG0zCHr050DSCNQLa6GOCl2+pqC+vtlGBenFwGusY1VlALbwbr0OsXOummFJ
+9/LK2fSh+dSi3wxUvrxcZRYyWHWrT01FcCO76F897RZrqWpA9q+55z/OStkMF3Cv
+IOUr92pMLFP5yopl9SO5SlLjXD0eklnCtGquSRl7+1VD5WCs/fO2BZABEQMxcU17
+2DtD744Bwhgk+o6KkahqtSa5WUcsBDDmjAmn/661Sk8NJJQ3hD421rU+eyVg+j13
+4hjKC1WvNcb8rK7QxfT2/ou6BWX9h0K5evizhV4WFnkjT9qnPzV0oWSOGbKVDmjm
+baZ4Nle3a1xvhS3ofTUhxcCFOzR4PRNhDkbUzi8r26fjgcDoJnmU0eWRQSyZT/X9
++xpN0SQ+a9hpGlhGl2P/VXcBym3touEcYZvCd6etX8NFtR4FCRSX295dsxIM0Qv9
+n1BJHqCvxQrJntgAVe9Ya3rsqCglZFQyvyo2/IXeWf+TGQ01gfA1K1DFac4cnkin
+RrztTcXFgJoPtTHHJWIZtGMdG9mXI8uKNv1bry0bHoWevzdqV70=
+=db0q
+-----END PGP SIGNATURE-----