summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwasertech2022-11-14 17:24:49 +0100
committerwasertech2022-11-14 17:24:49 +0100
commit7f1d846a251e678bbb4dc74cb6942c504463f357 (patch)
tree2116800e8813648cdde714c88a0e6b8c1ac62f34
downloadaur-7f1d846a251e678bbb4dc74cb6942c504463f357.tar.gz
added gruut
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore5
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD142
-rw-r--r--PKGBUILD_EXTRAS0
5 files changed, 193 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..91a1fe46412c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = python-gruut
+ pkgdesc = A tokenizer, text cleaner, and phonemizer for many human languages.
+ pkgver = 2.3.4
+ pkgrel = 00
+ url = https://github.com/rhasspy/gruut
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-babel
+ depends = python-dateparser
+ depends = python-gruut-ipa
+ depends = python-gruut-lang-en
+ depends = python-jsonlines
+ depends = python-networkx
+ depends = python-num2words
+ depends = python-numpy
+ depends = python-python-crfsuite
+ source = PKGBUILD_EXTRAS
+ source = https://files.pythonhosted.org/packages/4c/74/40e0bff02cf4daa3908c440e2111b20490c82080259f0114d0cfe07ce126/gruut-2.3.4.tar.gz
+ source = LICENSE
+ md5sums = SKIP
+ md5sums = 1f4e426132a083c1add08e7fc34aa1c2
+ md5sums = e18d31df63b289d2da1347a16b85d383
+
+pkgname = python-gruut
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a1e8e8db8d94
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/pkg/
+/src/
+*.tar.*
+*/
+*.whl
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..5c3f6e5f87ba
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2020 Michael Hansen
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b54d8855d2f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,142 @@
+# Maintainer: Danny Waser (Waser Technologies) <waser@waser.tech>
+
+export PIP_CONFIG_FILE=/dev/null
+export PIP_DISABLE_PIP_VERSION_CHECK=true
+
+pkgname=python-gruut
+epoch=
+pkgver=2.3.4
+pkgrel=00
+pkgdesc='A tokenizer, text cleaner, and phonemizer for many human languages.'
+arch=(any)
+url=https://github.com/rhasspy/gruut
+license=(MIT)
+depends=(python python-babel python-dateparser python-gruut-ipa python-gruut-lang-en python-jsonlines python-networkx python-num2words python-numpy python-crfsuite)
+## EXTRA_DEPENDS ##
+makedepends=()
+checkdepends=()
+provides=()
+conflicts=(${provides%=*}) # No quotes, to avoid an empty entry.
+source=(PKGBUILD_EXTRAS)
+md5sums=(SKIP)
+noextract=()
+source+=(https://files.pythonhosted.org/packages/4c/74/40e0bff02cf4daa3908c440e2111b20490c82080259f0114d0cfe07ce126/gruut-2.3.4.tar.gz)
+md5sums+=(1f4e426132a083c1add08e7fc34aa1c2)
+source+=(LICENSE)
+md5sums+=(e18d31df63b289d2da1347a16b85d383)
+
+_first_source() {
+ echo " ${source_i686[@]} ${source_x86_64[@]} ${source[@]}" |
+ tr ' ' '\n' | grep -Pv '^(PKGBUILD_EXTRAS)?$' | head -1
+}
+
+_vcs="$(grep -Po '^[a-z]+(?=\+)' <<< "$(_first_source)")"
+if [[ "$_vcs" ]]; then
+ makedepends+=("$(pkgfile --quiet /usr/bin/$_vcs)")
+ provides+=("${pkgname%-$_vcs}")
+ conflicts+=("${pkgname%-$_vcs}")
+fi
+
+_is_wheel() {
+ [[ $(_first_source) =~ \.whl$ ]]
+}
+
+if [[ _is_wheel &&
+ $(basename "$(_first_source)" | rev | cut -d- -f1 | rev) =~ ^manylinux ]]; then
+ options=(!strip) # https://github.com/pypa/manylinux/issues/119
+fi
+
+_dist_name() {
+ find "$srcdir" -mindepth 1 -maxdepth 1 -type d -printf '%f
+' |
+ grep -v '^_tmpenv$'
+}
+
+if [[ $(_first_source) =~ ^git+ ]]; then
+ _pkgver() {
+ ( set -o pipefail
+ cd "$srcdir/$(_dist_name)"
+ git describe --long --tags 2>/dev/null |
+ sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+ }
+
+ pkgver() { _pkgver; }
+fi
+
+_build() {
+ if _is_wheel; then return; fi
+ cd "$srcdir"
+ # See Arch Wiki/PKGBUILD/license.
+ # Get the first filename that matches.
+ local test_name
+ if [[ ${license[0]} =~ ^(BSD|MIT|ZLIB|Python)$ ]]; then
+ for test_name in LICENSE LICENSE.txt license.txt COPYING COPYING.md COPYING.rst COPYING.txt COPYRIGHT; do
+ if cp "$srcdir/$(_dist_name)/$test_name" "$srcdir/LICENSE" 2>/dev/null; then
+ break
+ fi
+ done
+ fi
+ # Use the latest version of pip, as Arch's version is historically out of
+ # date(!) and newer versions do fix bugs (sometimes).
+ python -mvenv --clear --system-site-packages _tmpenv
+ _tmpenv/bin/pip --quiet install -U pip
+ # Build the wheel (which we allow to fail) only after fetching the license.
+ # In order to isolate from ~/.pydistutils.cfg, we need to set $HOME to a
+ # temporary directory, and thus first $XDG_CACHE_HOME back to its real
+ # location, so that pip inserts the wheel in the wheel cache. We cannot
+ # use --global-option=--no-user-cfg instead because that fully disables
+ # wheels, causing a from-source build of build dependencies such as
+ # numpy/scipy.
+ XDG_CACHE_HOME="${XDG_CACHE_HOME:-"$HOME/.cache"}" HOME=_tmpenv \
+ _tmpenv/bin/pip wheel -v --no-deps --wheel-dir="$srcdir" \
+ "./$(_dist_name)" || true
+}
+
+build() { _build; }
+
+_check() {
+ # Define check(), possibly using _check as a helper, to run the tests.
+ # You may need to call `python setup.py build_ext -i` first.
+ if _is_wheel; then return; fi
+ cd "$srcdir/$(_dist_name)"
+ /usr/bin/python setup.py -q test
+}
+
+_package() {
+ cd "$srcdir"
+ # pypa/pip#3063: pip always checks for a globally installed version.
+ python -mvenv --clear --system-site-packages _tmpenv
+ _tmpenv/bin/pip install --prefix="$pkgdir/usr" \
+ --no-deps --ignore-installed --no-warn-script-location \
+ "$(ls ./*.whl 2>/dev/null || echo ./"$(_dist_name)")"
+ if [[ -d "$pkgdir/usr/bin" ]]; then # Fix entry points.
+ python="#!$(readlink -f _tmpenv)/bin/python"
+ for f in "$pkgdir/usr/bin/"*; do
+ # Like [[ "$(head -n1 "$f")" = "#!$(readlink -f _tmpenv)/bin/python" ]]
+ # but without bash warning on null bytes in "$f" (if it is actually
+ # a compiled executable, not an entry point).
+ if python -c 'import os, sys; sys.exit(not open(sys.argv[1], "rb").read().startswith(os.fsencode(sys.argv[2]) + b"\n"))' "$f" "$python"; then
+ sed -i '1c#!/usr/bin/python' "$f"
+ fi
+ done
+ fi
+ if [[ -d "$pkgdir/usr/etc" ]]; then
+ mv "$pkgdir/usr/etc" "$pkgdir/etc"
+ fi
+ if [[ -f LICENSE ]]; then
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ fi
+}
+
+package() { _package; }
+
+. "$(dirname "$BASH_SOURCE")/PKGBUILD_EXTRAS"
+
+# Remove makedepends already in depends (which may have been listed for the
+# first build, but autodetected on the second.
+makedepends=($(printf '%s\n' "${makedepends[@]}" |
+ grep -Pwv "^($(IFS='|'; echo "${depends[*]}"))$"))
+: # Apparently ending with makedepends assignment sometimes fails.
diff --git a/PKGBUILD_EXTRAS b/PKGBUILD_EXTRAS
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/PKGBUILD_EXTRAS