summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2018-07-31 15:38:44 +0200
committerChristopher Arndt2018-07-31 15:40:36 +0200
commitaaa2327b3e420101111f1f0fa9559f6f4464133b (patch)
tree39ec565d2e337b41c4c812547c81439c1b38f4d5
downloadaur-aaa2327b3e420101111f1f0fa9559f6f4464133b.tar.gz
Add new PKGBUILD for 'python-guizero'
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD28
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..428bb0ea2561
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-guizero
+ pkgdesc = Python module to allow learners to easily create GUIs
+ pkgver = 0.5.3
+ pkgrel = 1
+ url = https://github.com/lawsie/guizero
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python-pillow
+ source = https://files.pythonhosted.org/packages/source/g/guizero/guizero-0.5.3.tar.gz
+ source = https://raw.githubusercontent.com/lawsie/guizero/master/license.txt
+ md5sums = 4d6f6274a5bec5f82e45ae5f814c1f4a
+ md5sums = 9670acd16790b84f21178f2b940a96e2
+
+pkgname = python-guizero
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..18492d08193f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+pkg
+src
+license.txt
+guizero-*.tar.gz
+python-guizero-*.pkg.tar.xz
+python-guizero-*.src.tar.gz
+.AURINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b05c3a14e37
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+pkgname=('python-guizero')
+_module='guizero'
+pkgver='0.5.3'
+pkgrel=1
+pkgdesc="Python module to allow learners to easily create GUIs"
+url="https://github.com/lawsie/guizero"
+depends=('python-pillow')
+makedepends=('python-setuptools')
+license=('BSD')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/g/guizero/guizero-${pkgver}.tar.gz"
+ 'https://raw.githubusercontent.com/lawsie/guizero/master/license.txt')
+md5sums=('4d6f6274a5bec5f82e45ae5f814c1f4a'
+ '9670acd16790b84f21178f2b940a96e2')
+
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 "$srcdir/license.txt" -t "$pkgdir/usr/share/licenses/$pkgname"
+}