summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph Lansdowne2020-09-28 22:49:53 +0100
committerJoseph Lansdowne2020-09-28 22:50:28 +0100
commit3dd2ed8f7c1176e8b05c91758f750cee874074d0 (patch)
tree8d678a460e96f45f784dd608b978b20e62942c47
downloadaur-3dd2ed8f7c1176e8b05c91758f750cee874074d0.tar.gz
python-gw2buildutil 0.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b3bb05b4fa2e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-gw2buildutil
+ pkgdesc = Python 3 library for working with Guild Wars 2 builds
+ pkgver = 0.1
+ pkgrel = 1
+ url = http://ikn.org.uk/lib/gw2buildutil
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python>=3.7
+ source = http://ikn.org.uk/download/lib/gw2buildutil/gw2buildutil-0.1.tar.gz
+ sha1sums = 06daf098b1d65a06118b5cffd0eb834b40cbc37a
+
+pkgname = python-gw2buildutil
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b9f8b6f6dd19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Joseph Lansdowne <J49137@gmail.com>
+_pkgname=gw2buildutil
+pkgname=python-$_pkgname
+pkgver=0.1
+pkgrel=1
+pkgdesc="Python 3 library for working with Guild Wars 2 builds"
+arch=(any)
+url=http://ikn.org.uk/lib/gw2buildutil
+license=(BSD)
+makedepends=(python-setuptools)
+depends=("python>=3.7")
+source=("http://ikn.org.uk/download/lib/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha1sums=('06daf098b1d65a06118b5cffd0eb834b40cbc37a')
+
+build () {
+ cd "$srcdir/${_pkgname}-$pkgver"
+ make
+}
+
+package () {
+ cd "$srcdir/${_pkgname}-$pkgver"
+ make DESTDIR="$pkgdir" prefix=/usr install
+ install -D LICENSE "$pkgdir"/usr/share/licenses/"$_pkgname"/LICENSE
+}