summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSrevin Saju2020-12-29 20:41:50 +0300
committerSrevin Saju2020-12-29 20:41:50 +0300
commit128f8e5e3ac5f7ccc971cf803d3f0216b0f1b300 (patch)
treedc931e009fbe3f8fe8b5ac7314ed08ea064613a3
parentd8b0be300256680607d7ad52446d4c3385a509ac (diff)
downloadaur-128f8e5e3ac5f7ccc971cf803d3f0216b0f1b300.tar.gz
Bump version for gwebsockets
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61e82f473a9e..674736f6dd3e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
-pkgbase = gwebsockets-git
+pkgbase = python-gwebsockets-git
pkgdesc = A websocket server written in Python
- pkgver = 0.7.g
+ pkgver = v0.7
pkgrel = 5
url = https://github.com/sugarlabs/gwebsockets
arch = any
license = Apache-2.0
makedepends = python-setuptools
+ provides = python-gwebsockets
+ conflicts = python-gwebsockets
source = git+https://github.com/sugarlabs/gwebsockets.git
sha256sums = SKIP
-pkgname = gwebsockets-git
+pkgname = python-gwebsockets-git
diff --git a/PKGBUILD b/PKGBUILD
index 7822114e37a7..d493b42abd34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
-# Maintainer: Srevin Saju <srevin03@gmail.com>
-pkgname=gwebsockets-git
-pkgver=0.7.g
+# Maintainer: Srevin Saju <srevinsaju@sugarlabs.org>
+pkgname=python-gwebsockets-git
+pkgver=v0.7
pkgrel=5
pkgdesc="A websocket server written in Python"
arch=('any')
@@ -8,16 +8,18 @@ url="https://github.com/sugarlabs/gwebsockets"
license=('Apache-2.0')
makedepends=('python-setuptools')
source=("git+https://github.com/sugarlabs/gwebsockets.git")
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
sha256sums=('SKIP')
build() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/gwebsockets"
python setup.py build
}
package() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/gwebsockets"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}