summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlair Bonnett2022-01-12 07:53:29 +0100
committerBlair Bonnett2022-01-12 07:53:29 +0100
commit9f7f65f253de969c9e160cd5794aea7c653e5de8 (patch)
tree2d0a652fde83d65630c9e68536547d7d96e43f66
parent5c026d59e0bfbf1d4cae9cbef46aef9545950159 (diff)
downloadaur-9f7f65f253de969c9e160cd5794aea7c653e5de8.tar.gz
Update to 0.13.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95593fd1b0ce..946aa6350107 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-h5netcdf
pkgdesc = Pythonic interface to netCDF4 via h5py
- pkgver = 0.12.0
+ pkgver = 0.13.0
pkgrel = 1
url = https://github.com/shoyer/h5netcdf
arch = any
@@ -9,7 +9,7 @@ pkgbase = python-h5netcdf
checkdepends = python-pytest
makedepends = python-setuptools
depends = python-h5py
- source = https://files.pythonhosted.org/packages/source/h/h5netcdf/h5netcdf-0.12.0.tar.gz
- sha256sums = 6d3623f9ea46747249333792f13b515d05ff652dcec1ee436fa969bee03a8dd5
+ source = https://files.pythonhosted.org/packages/source/h/h5netcdf/h5netcdf-0.13.0.tar.gz
+ sha256sums = 43ecc47614ae804879b51cc95d6264520fcddfe83ccfa7d92b6e236da7dc25db
pkgname = python-h5netcdf
diff --git a/PKGBUILD b/PKGBUILD
index aec4877d157c..58dd4a88bf27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: richli <rich at dranek dot com>
pkgname=python-h5netcdf
-pkgver=0.12.0
+pkgver=0.13.0
pkgrel=1
pkgdesc="Pythonic interface to netCDF4 via h5py"
arch=('any')
@@ -11,25 +11,27 @@ license=('BSD')
depends=('python-h5py')
makedepends=('python-setuptools')
checkdepends=('python-netcdf4' 'python-pytest')
+
+_pypi=h5netcdf
source=(
- "https://files.pythonhosted.org/packages/source/h/h5netcdf/h5netcdf-$pkgver.tar.gz"
+ "https://files.pythonhosted.org/packages/source/${_pypi::1}/$_pypi/$_pypi-$pkgver.tar.gz"
)
sha256sums=(
- '6d3623f9ea46747249333792f13b515d05ff652dcec1ee436fa969bee03a8dd5'
+ '43ecc47614ae804879b51cc95d6264520fcddfe83ccfa7d92b6e236da7dc25db'
)
build() {
- cd "$srcdir/h5netcdf-${pkgver}"
+ cd "$_pypi-${pkgver}"
python setup.py build
}
check() {
- cd "$srcdir/h5netcdf-${pkgver}"
+ cd "$_pypi-${pkgver}"
PYTHONPATH="./build/lib" PYTHONDONTWRITEBYTECODE=1 pytest -v --disable-warnings
}
package() {
- cd "$srcdir/h5netcdf-${pkgver}"
+ cd "$_pypi-${pkgver}"
python setup.py install --prefix=/usr --root="$pkgdir" --skip-build --optimize 1
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}