summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchrisjbillington2020-06-11 12:20:17 -0400
committerchrisjbillington2020-06-11 12:20:17 -0400
commit03c00ccd54508d8d00e2e0ea7ce3a711dea5dcc1 (patch)
tree91b17dc93d26c7c0c7dbf5c5e4ab2361a762da5a
parente8e847db4db03710e4da69e93464045a1ad913ee (diff)
downloadaur-03c00ccd54508d8d00e2e0ea7ce3a711dea5dcc1.tar.gz
Remove Python2 and OpenMPI
This package is now based on the PKGBUILD from [community]/h5py, and is not built with openMPI. A separate package can be made for an openMPI version, as is the case in [community]. Removed Python2 packages, allowing Python 3 packages to be built.
-rw-r--r--.SRCINFO38
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD65
3 files changed, 45 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 035379874256..7639bea73980 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,39 +1,21 @@
pkgbase = python-h5py-git
- pkgdesc = General-purpose Python bindings for the HDF5 library -- latest commit, with mpi
- pkgver = r968.3d1edda
+ pkgdesc = General-purpose Python bindings for the HDF5 library
+ pkgver = r1197.ff214cdd
pkgrel = 1
- url = http://www.h5py.org/
+ url = https://www.h5py.org/
arch = x86_64
license = BSD
- makedepends = hdf5-openmpi
+ checkdepends = python-pytest
makedepends = cython
- makedepends = cython2
- makedepends = python-numpy
- makedepends = python2-numpy
- makedepends = python-six
- makedepends = python2-six
makedepends = python-pkgconfig
- makedepends = python2-pkgconfig
- makedepends = python-mpi4py
- makedepends = python2-mpi4py
+ depends = hdf5
+ depends = python-numpy
+ depends = python-six
provides = python-h5py
- provides = python2-h5py
- source = h5py::git+https://github.com/h5py/h5py.git#branch=master
+ conflicts = python-h5py
+ conflicts = hdf5-openmpi
+ source = git+https://github.com/h5py/h5py
md5sums = SKIP
pkgname = python-h5py-git
- depends = hdf5-openmpi
- depends = cython
- depends = python-numpy
- depends = python-six
- depends = python-pkgconfig
- depends = python-mpi4py
-
-pkgname = python2-h5py-git
- depends = hdf5-openmpi
- depends = cython2
- depends = python2-numpy
- depends = python2-six
- depends = python2-pkgconfig
- depends = python2-mpi4py
diff --git a/.gitignore b/.gitignore
index ff1b5e74e79f..83502c2857f9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,3 +4,4 @@ src/
*.tar.gz
*.tar.xz
h5py/
+*.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index 0efe172798ea..eebcafcd29d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
-# $Id$
-# Maintainer: Grey Christoforo <first name at last name dot net>
+# Maintainer: Chris Billington <chrisjbillington@gmail.com>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Bruno Pagani <archange@archlinux.org>
+# Contributor: Andrzej Giniewicz <gginiu@gmail.com>
+# Contributor: Rich Li <rich@dranek.com>
+# Contributor: Sebastien Binet <binet@lblbox>
_pkg=h5py
-pkgbase=python-${_pkg}-git
-pkgname=(python-${_pkg}-git python2-${_pkg}-git)
-pkgver=r968.3d1edda
+pkgname=python-${_pkg}-git
+pkgver=r1197.ff214cdd
pkgrel=1
-pkgdesc="General-purpose Python bindings for the HDF5 library -- latest commit, with mpi"
-url="http://www.h5py.org/"
-arch=('x86_64')
-license=('BSD')
-makedepends=("hdf5-openmpi" 'cython' 'cython2' 'python-numpy' 'python2-numpy' 'python-six' 'python2-six'
- 'python-pkgconfig' 'python2-pkgconfig' 'python-mpi4py' 'python2-mpi4py')
-provides=(python-${_pkg} python2-${_pkg})
-conflics=${provides}
-
-source=("${_pkg}"'::git+https://github.com/h5py/h5py.git#branch=master')
+pkgdesc="General-purpose Python bindings for the HDF5 library"
+arch=(x86_64)
+url="https://www.h5py.org/"
+license=(BSD)
+depends=(hdf5 python-numpy python-six)
+makedepends=(cython python-pkgconfig)
+checkdepends=(python-pytest)
+conflicts=(python-h5py hdf5-openmpi)
+provides=(python-h5py)
+source=("git+https://github.com/h5py/h5py")
md5sums=('SKIP')
pkgver() {
@@ -23,24 +26,24 @@ pkgver() {
printf "r%s.%s" "$(git rev-list HEAD --count --first-parent)" "$(git rev-parse --short HEAD)"
}
-package_python2-h5py-git() {
- depends=('hdf5-openmpi' 'cython2' 'python2-numpy' 'python2-six' 'python2-pkgconfig' 'python2-mpi4py')
- cd "${_pkg}"
- python2 setup.py configure --mpi
- python2 setup.py install --root="${pkgdir}" --optimize 1
- #install -d644 "${pkgdir}/usr/share/licenses/${pkgname}"
- #install -Dm644 "./licenses/*" "${pkgdir}/usr/share/licenses/${pkgname}"
- install -D licenses/license.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+prepare() {
+ # Remove RPATH
+ sed -i "s/settings\\['runtime_library_dirs'\\] = settings\\['library_dirs'\\]/pass/" ${_pkg}/setup_build.py
}
+build() {
+ cd ${_pkg}
+ python setup.py build
+}
-package_python-h5py-git() {
- depends=('hdf5-openmpi' 'cython' 'python-numpy' 'python-six' 'python-pkgconfig' 'python-mpi4py')
- cd "${_pkg}"
- python2 setup.py configure --mpi
- python setup.py install --root="${pkgdir}" --optimize 1
- #install -d644 "${pkgdir}/usr/share/licenses/${pkgname}"
- #install -Dm644 "./licenses/*" "${pkgdir}/usr/share/licenses/${pkgname}"
- install -D licenses/license.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+check() {
+ cd ${_pkg}
+ python setup.py test || warning "Tests failed"
}
+package() {
+ cd ${_pkg}
+ python setup.py install --root="${pkgdir}" --skip-build --optimize=1
+
+ install -Dm644 licenses/license.txt -t "${pkgdir}"/usr/share/licenses/${pkgname}/
+}