summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2023-04-12 14:24:32 +0800
committerUniversebenzene2023-04-12 14:24:32 +0800
commitc4c3dcaa9b2b83574c79637cb31029ef310bb4d3 (patch)
treea8c0fcbd9cee15a90f45dfdd6ec9fffe995ce1d4
parent66fc0a329b9cfb6c2c7639f521e7d1e60a241172 (diff)
downloadaur-c4c3dcaa9b2b83574c79637cb31029ef310bb4d3.tar.gz
Update to version 0.14.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD29
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1eb5f3c4dc6d..c3a8a42c6b9b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-h5pyd
pkgdesc = h5py distributed - Python client library for HDF Rest API
- pkgver = 0.13.1
+ pkgver = 0.14.0
pkgrel = 1
url = https://github.com/HDFGroup/h5pyd
arch = any
@@ -13,12 +13,12 @@ pkgbase = python-h5pyd
makedepends = python-setuptools
makedepends = python-pkgconfig
makedepends = python-sphinx-furo
- source = h5pyd-0.13.1.tar.gz::https://github.com/HDFGroup/h5pyd/archive/463c960e1c4da7d1f3da33bcd7fdfb0e38133fea.tar.gz
+ source = h5pyd-0.14.0.tar.gz::https://github.com/HDFGroup/h5pyd/archive/refs/tags/v0.14.0.tar.gz
source = https://raw.githubusercontent.com/h5py/h5py/master/examples/bytesio.py
source = https://raw.githubusercontent.com/h5py/h5py/master/examples/swmr_inotify_example.py
source = https://raw.githubusercontent.com/h5py/h5py/master/examples/swmr_multiprocess.py
source = fix-h5type-test.patch
- md5sums = fd80a51cc6eb6f59cc6d829485f428d5
+ md5sums = 72b997cccfd0b9c75e5e24ca24779af4
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 2af4ba340bed..c291c1904f97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgbase=python-h5pyd
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=0.13.1
-_commit="463c960e1c4da7d1f3da33bcd7fdfb0e38133fea"
+pkgver=0.14.0
+#_commit="490be2b6cc5ee3a697e5929e4e9f6bb5b7ae4548"
pkgrel=1
pkgdesc="h5py distributed - Python client library for HDF Rest API "
arch=('any')
@@ -22,12 +22,13 @@ checkdepends=('python-pytest'
'python-requests-unixsocket'
'python-adal')
#source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
-source=("${_pyname}-${pkgver}.tar.gz::https://github.com/HDFGroup/h5pyd/archive/${_commit}.tar.gz"
+#source=("${_pyname}-${pkgver}.tar.gz::https://github.com/HDFGroup/h5pyd/archive/${_commit}.tar.gz"
+source=("${_pyname}-${pkgver}.tar.gz::https://github.com/HDFGroup/h5pyd/archive/refs/tags/v${pkgver}.tar.gz"
"https://raw.githubusercontent.com/h5py/h5py/master/examples/bytesio.py"
"https://raw.githubusercontent.com/h5py/h5py/master/examples/swmr_inotify_example.py"
"https://raw.githubusercontent.com/h5py/h5py/master/examples/swmr_multiprocess.py"
'fix-h5type-test.patch')
-md5sums=('fd80a51cc6eb6f59cc6d829485f428d5'
+md5sums=('72b997cccfd0b9c75e5e24ca24779af4'
'SKIP'
'SKIP'
'SKIP'
@@ -38,8 +39,8 @@ get_pyver() {
}
prepare() {
-# cd ${srcdir}/${_pyname}-${pkgver}
- cd ${srcdir}/${_pyname}-${_commit}
+ cd ${srcdir}/${_pyname}-${pkgver}
+# cd ${srcdir}/${_pyname}-${_commit}
ln -rs ${srcdir}/*.py examples
sed -i -e "/GH/s/GH/GH\%s/" -e "/PR/s/PR/PR\%s/" docs/conf.py
@@ -47,8 +48,8 @@ prepare() {
}
build() {
-# cd ${srcdir}/${_pyname}-${pkgver}
- cd ${srcdir}/${_pyname}-${_commit}
+ cd ${srcdir}/${_pyname}-${pkgver}
+# cd ${srcdir}/${_pyname}-${_commit}
python setup.py build
python setup.py egg_info
# python -m build --wheel --no-isolation
@@ -62,8 +63,8 @@ build() {
}
check() {
-# cd ${srcdir}/${_pyname}-${pkgver}
- cd ${srcdir}/${_pyname}-${_commit}
+ cd ${srcdir}/${_pyname}-${pkgver}
+# cd ${srcdir}/${_pyname}-${_commit}
pytest || warning "Tests failed" #${PWD}/test \ -vv --color=yes
# PYTHONPATH="build/lib" pytest #|| warning "Tests failed" #${PWD}/test \
@@ -82,8 +83,8 @@ package_python-h5pyd() {
'python-google-auth'
'python-adal')
optdepends=('python-h5pyd-doc: Documentation for h5pyd')
-# cd ${srcdir}/${_pyname}-${pkgver}
- cd ${srcdir}/${_pyname}-${_commit}
+ cd ${srcdir}/${_pyname}-${pkgver}
+# cd ${srcdir}/${_pyname}-${_commit}
install -D -m644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
@@ -93,9 +94,9 @@ package_python-h5pyd() {
package_python-h5pyd-doc() {
pkgdesc="Documentation for Python h5pyd"
-# cd ${srcdir}/${_pyname}-${pkgver}/build/sphinx
+ cd ${srcdir}/${_pyname}-${pkgver}/build/sphinx
# cd ${srcdir}/${_pyname}-${pkgver}/docs/_build
- cd ${srcdir}/${_pyname}-${_commit}/build/sphinx
+# cd ${srcdir}/${_pyname}-${_commit}/build/sphinx
install -D -m644 ../../COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"