summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2023-01-04 11:31:31 +0800
committerUniversebenzene2023-01-04 11:31:31 +0800
commitd9baa4f976d105478240566a5fb192697ae51b85 (patch)
tree1e5740829b3862a3cb63e1266625b6736d1f779a
parentfb8258c707c1aa66b6cab19f30f55ec43ff16ff7 (diff)
downloadaur-d9baa4f976d105478240566a5fb192697ae51b85.tar.gz
Update to version 0.12.6
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD44
2 files changed, 24 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 66faa2df2555..ebed87c288d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-h5pyd
pkgdesc = h5py distributed - Python client library for HDF Rest API
- pkgver = 0.12.1
+ pkgver = 0.12.6
pkgrel = 1
url = https://github.com/HDFGroup/h5pyd
arch = any
@@ -12,16 +12,9 @@ pkgbase = python-h5pyd
checkdepends = python-adal
makedepends = python-setuptools
makedepends = python-pkgconfig
- makedepends = python-sphinx-furo
- source = https://files.pythonhosted.org/packages/source/h/h5pyd/h5pyd-0.12.1.tar.gz
- source = https://raw.githubusercontent.com/h5py/h5py/master/examples/bytesio.py
- source = https://raw.githubusercontent.com/h5py/h5py/master/examples/swmr_inotify_example.py
- source = https://raw.githubusercontent.com/h5py/h5py/master/examples/swmr_multiprocess.py
+ source = https://files.pythonhosted.org/packages/source/h/h5pyd/h5pyd-0.12.6.tar.gz
source = fix-h5type-test.patch
- md5sums = 67866937cc8bd8724a12eb313373f7b3
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
+ md5sums = 7f03fc8e0156061cb69528aa06355878
md5sums = fce3d7b92909be61507392ab33bfce0a
pkgname = python-h5pyd
@@ -36,6 +29,3 @@ pkgname = python-h5pyd
depends = python-google-auth
depends = python-adal
optdepends = python-h5pyd-doc: Documentation for h5pyd
-
-pkgname = python-h5pyd-doc
- pkgdesc = Documentation for Python h5pyd
diff --git a/PKGBUILD b/PKGBUILD
index 984f10fb7ea1..e0f16710c64b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
pkgbase=python-h5pyd
_pyname=${pkgbase#python-}
-pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=0.12.1
+pkgname=("python-${_pyname}")
+#"python-${_pyname}-doc")
+pkgver=0.12.6
pkgrel=1
pkgdesc="h5py distributed - Python client library for HDF Rest API "
arch=('any')
@@ -11,24 +12,21 @@ url="https://github.com/HDFGroup/h5pyd"
license=('BSD')
makedepends=('python-setuptools'
# 'python-wheel'
- 'python-pkgconfig'
+ 'python-pkgconfig')
# 'python-build'
# 'python-installer'
- 'python-sphinx-furo')
+# 'python-sphinx-furo')
checkdepends=('python-pytest'
'python-numpy'
'python-pytz'
'python-requests-unixsocket'
'python-adal')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
- "https://raw.githubusercontent.com/h5py/h5py/master/examples/bytesio.py"
- "https://raw.githubusercontent.com/h5py/h5py/master/examples/swmr_inotify_example.py"
- "https://raw.githubusercontent.com/h5py/h5py/master/examples/swmr_multiprocess.py"
+# "https://raw.githubusercontent.com/h5py/h5py/master/examples/bytesio.py"
+# "https://raw.githubusercontent.com/h5py/h5py/master/examples/swmr_inotify_example.py"
+# "https://raw.githubusercontent.com/h5py/h5py/master/examples/swmr_multiprocess.py"
'fix-h5type-test.patch')
-md5sums=('67866937cc8bd8724a12eb313373f7b3'
- 'SKIP'
- 'SKIP'
- 'SKIP'
+md5sums=('7f03fc8e0156061cb69528aa06355878'
'fce3d7b92909be61507392ab33bfce0a')
#get_pyver() {
@@ -38,8 +36,8 @@ md5sums=('67866937cc8bd8724a12eb313373f7b3'
prepare() {
cd ${srcdir}/${_pyname}-${pkgver}
- ln -rs ${srcdir}/*.py examples
- sed -i -e "/GH/s/GH/GH\%s/" -e "/PR/s/PR/PR\%s/" docs/conf.py
+# ln -rs ${srcdir}/*.py examples
+# sed -i -e "/GH/s/GH/GH\%s/" -e "/PR/s/PR/PR\%s/" docs/conf.py
patch -Np1 -i "${srcdir}/fix-h5type-test.patch"
}
@@ -49,7 +47,7 @@ build() {
# python -m build --wheel --no-isolation
msg "Building Docs"
- python setup.py build_sphinx
+# python setup.py build_sphinx
# ln -rs ${srcdir}/${_pyname}-${pkgver}/${_pyname/-/_}*egg-info \
# build/lib/${_pyname/-/_}-${pkgver}-py$(get_pyver .).egg-info
# cd ${srcdir}/${_pyname}-${pkgver}/docs
@@ -84,12 +82,12 @@ package_python-h5pyd() {
# python -m installer --destdir="${pkgdir}" dist/*.whl
}
-package_python-h5pyd-doc() {
- pkgdesc="Documentation for Python h5pyd"
- cd ${srcdir}/${_pyname}-${pkgver}/build/sphinx
-# cd ${srcdir}/${_pyname}-${pkgver}/docs/_build
-
- install -D -m644 ../../COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
- install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
- cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"
-}
+#package_python-h5pyd-doc() {
+# pkgdesc="Documentation for Python h5pyd"
+# cd ${srcdir}/${_pyname}-${pkgver}/build/sphinx
+## cd ${srcdir}/${_pyname}-${pkgver}/docs/_build
+#
+# install -D -m644 ../../COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
+# install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
+# cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"
+#}