summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP-Ellis2023-05-21 09:38:22 +1000
committerJP-Ellis2023-05-21 09:38:22 +1000
commit349838fa13fe2496de6fade9d5f52df4acfb3c4e (patch)
tree9945fbbc8d9b3351406cf8ceb081cc0352bb1378
parent4cffae18d2a347b86c76e2cbbf6cbfef207d4334 (diff)
downloadaur-349838fa13fe2496de6fade9d5f52df4acfb3c4e.tar.gz
v1.2.3
Signed-off-by: JP-Ellis <josh@jpellis.me>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 397c552ea100..d9b7171affb7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = python-habanero
pkgdesc = Habanero is a low level client for working with Crossref's search API.
- pkgver = 1.0.0
+ pkgver = 1.2.3
pkgrel = 1
url = https://pypi.org/project/habanero/
arch = any
license = GPL
makedepends = python-setuptools
depends = python
- source = https://files.pythonhosted.org/packages/source/h/habanero/habanero-1.0.0.tar.gz
- sha256sums = 2763debc455841e28715ff20c9884249e1b2eecfd22c20967928e1eb657a0fe5
+ depends = python-requests
+ depends = python-tqdm
+ source = https://files.pythonhosted.org/packages/source/h/habanero/habanero-1.2.3.tar.gz
+ sha256sums = 196f9e01b42dad2cd829dc5d0bbe466232daf6ad5f1b0ee7098a57927b17e908
pkgname = python-habanero
diff --git a/PKGBUILD b/PKGBUILD
index 07d7aee3bd6a..c9d9c92f17d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,21 @@
# Maintainer: JP-Ellis <josh@jpellis.me>
pkgname=python-habanero
_name=${pkgname#python-}
-pkgver=1.0.0
+pkgver=1.2.3
pkgrel=1
pkgdesc="Habanero is a low level client for working with Crossref's search API."
arch=('any')
url="https://pypi.org/project/habanero/"
license=('GPL')
-depends=('python')
+depends=(
+ 'python'
+ 'python-requests'
+ 'python-tqdm'
+)
makedepends=('python-setuptools')
optdepends=()
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('2763debc455841e28715ff20c9884249e1b2eecfd22c20967928e1eb657a0fe5')
+sha256sums=('196f9e01b42dad2cd829dc5d0bbe466232daf6ad5f1b0ee7098a57927b17e908')
noextract=()
build() {