summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorŁukasz Pożarlik2019-05-19 11:53:37 +0200
committerŁukasz Pożarlik2019-05-19 11:53:37 +0200
commitd25665857c7129a6cef90f072daccb42998e76c0 (patch)
tree5fede27a8902233c9f30031bafe5658b4192f80b
downloadaur-d25665857c7129a6cef90f072daccb42998e76c0.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--LICENSE19
-rw-r--r--PKGBUILD41
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..74c89173a2da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = python-habitipy
+ pkgdesc = A set of scripts to interact with Habitica
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/ASMfreaK/habitipy
+ arch = any
+ license = MIT
+ makedepends = python-pbr>=1.9
+ makedepends = python2-pbr>=1.9
+ source = https://files.pythonhosted.org/packages/source/h/habitipy/habitipy-0.3.0.tar.gz
+ source = LICENSE
+ sha256sums = 6b2d01eab4da0b2b78280ce0f670c5f7b4c249e1b0794e544fa1f2f4d07ec2a3
+ sha256sums = 677a082f39faca4187bd171ae13be0ad128f413e82b159994a8ba412cd33a5f9
+
+pkgname = python-habitipy
+ depends = python-pbr
+ depends = python-requests
+ depends = python-plumbum
+
+pkgname = python2-habitipy
+ depends = python2-pbr
+ depends = python2-requests
+ depends = python2-plumbum
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..b367c984137a
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,19 @@
+Copyright (c) 2013, Phil Adams <http://philadams.net>
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of
+this software and associated documentation files (the "Software"), to deal in
+the Software without restriction, including without limitation the rights to
+use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies
+of the Software, and to permit persons to whom the Software is furnished to do
+so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d791c9bc0200
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Lukasz Pozarlik <lpozarlik@gmail.com>
+
+_name="habitipy"
+_module="$_name"
+
+pkgname=("python-$_module" "python2-$_module")
+pkgdesc="A set of scripts to interact with Habitica"
+pkgver="0.3.0"
+pkgrel=1
+url="https://github.com/ASMfreaK/habitipy"
+license=('MIT')
+arch=('any')
+makedepends=("python-pbr>=1.9" "python2-pbr>=1.9")
+source=("https://files.pythonhosted.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz"
+"LICENSE")
+sha256sums=('6b2d01eab4da0b2b78280ce0f670c5f7b4c249e1b0794e544fa1f2f4d07ec2a3'
+ '677a082f39faca4187bd171ae13be0ad128f413e82b159994a8ba412cd33a5f9')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+ python2 setup.py build
+}
+
+package_python-habitipy(){
+ depends=("python-pbr"
+ "python-requests"
+ "python-plumbum")
+ cd "$_name-$pkgver"
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
+ install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" ../LICENSE
+}
+
+package_python2-habitipy(){
+ depends=("python2-pbr"
+ "python2-requests"
+ "python2-plumbum")
+ cd "$_name-$pkgver"
+ python2 setup.py install --skip-build --root="$pkgdir" --optimize=1
+ install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" ../LICENSE
+}