summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s.2018-08-17 03:33:54 -0400
committerbrent s.2018-08-17 03:33:54 -0400
commit170e97c228d0543e238d27f7417eb6f3284626e3 (patch)
tree5ccae73e6a795891653d0392f92b66e425ab1015
downloadaur-170e97c228d0543e238d27f7417eb6f3284626e3.tar.gz
initial commit; setting up .gitignores and skeleton PKGBUILD
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore18
-rw-r--r--PKGBUILD29
-rw-r--r--hashID-3.1.4.zip.sig16
4 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b1cc91592cb5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by aurpkgs
+# Fri Aug 17 07:33:54 UTC 2018
+pkgbase = python-hashid
+ pkgdesc = Identify the different types of hashes used to encrypt data and especially passwords
+ pkgver = 3.1.4
+ pkgrel = 1
+ url = https://github.com/psypanda/hashID
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = python
+ depends = python2
+ source = https://files.pythonhosted.org/packages/source/h/hashID/hashID-3.1.4.zip
+ source = hashID-3.1.4.zip.sig
+ sha512sums = 598538454578cf71872950d43aab9fa8d274983646e2dc94462e5d3dcb0bee04c923cf8f6769cf5aa1a9d0e825c97cfa2560a11beebf1aeccc40648c90d03567
+ sha512sums = SKIP
+
+pkgname = python-hashid
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e16177da2907
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,18 @@
+*/
+.*.swp
+*.pkg.tar.xz
+src/
+pkg/
+*.tar
+*.tar.bz2
+*.tar.xz
+*.tar.gz
+*.tgz
+*.txz
+*.tbz
+*.tbz2
+*.zip
+*.run
+*.7z
+*.rar
+*.deb
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f50c969f1a98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: brent s. <bts[at]square-r00t[dot]net>
+validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
+# Bug reports can be filed at https://bugs.square-r00t.net/index.php?project=3
+# News updates for packages can be followed at https://devblog.square-r00t.net
+pkgname=python-hashid
+pkgver=3.1.4
+pkgrel=1
+pkgdesc="Identify the different types of hashes used to encrypt data and especially passwords"
+arch=( 'i686' 'x86_64' )
+url="https://github.com/psypanda/hashID"
+license=( 'GPL3' )
+depends=( 'python' 'python2' )
+makedepends=( ''python-distribute'' ''python2-distribute'' ''python'' ''python2'' )
+_pkgname=python-hashid
+install=
+changelog=
+noextract=()
+source=("https://files.pythonhosted.org/packages/source/h/hashID/hashID-3.1.4.zip"
+ "hashID-3.1.4.zip.sig")
+sha512sums=('598538454578cf71872950d43aab9fa8d274983646e2dc94462e5d3dcb0bee04c923cf8f6769cf5aa1a9d0e825c97cfa2560a11beebf1aeccc40648c90d03567'
+ 'SKIP')
+build() {
+ cd "${srcdir}/${_pkgname}/src"
+ make prefix=${pkgdir}/usr
+}
+package() {
+ install -D -m755 ${srcdir}/${_pkgname}/src/${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
+ install -D -m644 ${srcdir}/${_pkgname}/docs/README.html.en ${pkgdir}/usr/share/doc/${_pkgname}/README.html
+}
diff --git a/hashID-3.1.4.zip.sig b/hashID-3.1.4.zip.sig
new file mode 100644
index 000000000000..a36c7b9c3d6b
--- /dev/null
+++ b/hashID-3.1.4.zip.sig
@@ -0,0 +1,16 @@
+-----BEGIN PGP SIGNATURE-----
+
+iQIzBAABCgAdFiEEdIIx68vYCKFPXoXSjABML5NIH2sFAlt2elkACgkQjABML5NI
+H2tIig//R3rdOEwGko0AQ0LmcYCgSGUQEht37w6r0DM76gdFTfPlbGWcyuub76KK
+JmdN7QHnloJg8byKl87uYP6bcqbR/11QBrc7/V0lX4XizW69ET/n0mLh+dW21561
+Mef6sr2mU8jIHioJwjxEEE+7OwmQsszvA/4G+KcKca3mIIt6dVrcb4NxQiyoYcmK
++4joBePGz332+APMj2pIn7R+G2sT3/16vzuDin9rgx1jt/n/FZ38h3Njh3Re2Jex
+pE3EcjZdlPtXOzShdPp83yRi+3eqjxEHQ4mCw1CJJN6A9L4KL+HeQ47onE+E08jJ
+ZI/8VRuF0GEW69t9F+S3yDExIjLtcL6UKFDLwrjiWnWkKdXV8lb3YLqmo1N9783F
+ZA3bHL6nje7/XaZMsCDj6S1Ry2Cu6uNqMsnokSxvaCuUmwlzTaKXSaTR+fTZYgl4
+ZHR3KdYra1DTXlpCMo+vBvYJawiXJgYqbswNbLjP7cduASzHvN5tL3VndnClegbJ
+Hy3cAmWhsNttyVRy9wm/UeZab7zoGEoNIm+nj6vuG7XKJ+W1FahxLx8Xjx3C7EZL
+6MEzYBaFl6JVMkeNqy8b+oe7oW1/vR68pzzE4wPrpYHClv4Y3uc0iMA6dJe+1aD1
+DDRqtp/p/8J6ZNMtjw92tfNHOL/ma8XCqbVkfi3kdafCEcvi1OI=
+=2Xjp
+-----END PGP SIGNATURE-----