summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s2018-08-17 03:36:27 -0400
committerbrent s2018-08-17 03:36:27 -0400
commit85006385ee0047b9768c2a6c454ce57c1a30b57b (patch)
tree30b91fed2fa34ee5e9c1f37ef25f04dfdced968c
parent170e97c228d0543e238d27f7417eb6f3284626e3 (diff)
downloadaur-85006385ee0047b9768c2a6c454ce57c1a30b57b.tar.gz
cleaning up
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
2 files changed, 23 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1cc91592cb5..bdbc59db4ef5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,17 @@
-# Generated by aurpkgs
-# Fri Aug 17 07:33:54 UTC 2018
+# Generated by mksrcinfo v8
+# Fri Aug 17 07:36:27 UTC 2018
pkgbase = python-hashid
pkgdesc = Identify the different types of hashes used to encrypt data and especially passwords
pkgver = 3.1.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/psypanda/hashID
arch = i686
arch = x86_64
license = GPL3
+ makedepends = python-distribute
+ makedepends = python2-distribute
+ makedepends = python
+ makedepends = python2
depends = python
depends = python2
source = https://files.pythonhosted.org/packages/source/h/hashID/hashID-3.1.4.zip
@@ -16,3 +20,5 @@ pkgbase = python-hashid
sha512sums = SKIP
pkgname = python-hashid
+ depends = python
+
diff --git a/PKGBUILD b/PKGBUILD
index f50c969f1a98..15c2a82c506f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,26 +4,30 @@ validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
# News updates for packages can be followed at https://devblog.square-r00t.net
pkgname=python-hashid
pkgver=3.1.4
-pkgrel=1
+pkgrel=2
pkgdesc="Identify the different types of hashes used to encrypt data and especially passwords"
arch=( 'i686' 'x86_64' )
url="https://github.com/psypanda/hashID"
license=( 'GPL3' )
depends=( 'python' 'python2' )
makedepends=( ''python-distribute'' ''python2-distribute'' ''python'' ''python2'' )
-_pkgname=python-hashid
+_pkgname="hashID"
install=
changelog=
noextract=()
-source=("https://files.pythonhosted.org/packages/source/h/hashID/hashID-3.1.4.zip"
- "hashID-3.1.4.zip.sig")
+source=("https://files.pythonhosted.org/packages/source/h/${_pkgname}/${_pkgname}-${pkgver}.zip"
+ "${_pkgname}-${pkgver}.zip.sig")
sha512sums=('598538454578cf71872950d43aab9fa8d274983646e2dc94462e5d3dcb0bee04c923cf8f6769cf5aa1a9d0e825c97cfa2560a11beebf1aeccc40648c90d03567'
'SKIP')
-build() {
- cd "${srcdir}/${_pkgname}/src"
- make prefix=${pkgdir}/usr
+
+package_python-hashid() {
+ depends=('python')
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python3 setup.py install --root="${pkgdir}" --optimize=1
}
-package() {
- install -D -m755 ${srcdir}/${_pkgname}/src/${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
- install -D -m644 ${srcdir}/${_pkgname}/docs/README.html.en ${pkgdir}/usr/share/doc/${_pkgname}/README.html
+
+package_python2-hashid() {
+ depends=('python2')
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
}