summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s2018-12-03 06:34:52 -0500
committerbrent s2018-12-03 06:34:52 -0500
commit90393afd55487d023f1899aa225e5a0ff06d9b5d (patch)
treebd39971390caf533878f01bf70247216ee78319c
parent85006385ee0047b9768c2a6c454ce57c1a30b57b (diff)
downloadaur-90393afd55487d023f1899aa225e5a0ff06d9b5d.tar.gz
updating makedep
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bdbc59db4ef5..9fbf9511e09f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Aug 17 07:36:27 UTC 2018
+# Mon Dec 3 11:34:52 UTC 2018
pkgbase = python-hashid
pkgdesc = Identify the different types of hashes used to encrypt data and especially passwords
pkgver = 3.1.4
@@ -12,6 +12,8 @@ pkgbase = python-hashid
makedepends = python2-distribute
makedepends = python
makedepends = python2
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
depends = python
depends = python2
source = https://files.pythonhosted.org/packages/source/h/hashID/hashID-3.1.4.zip
diff --git a/PKGBUILD b/PKGBUILD
index 15c2a82c506f..01bdc7d137fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ arch=( 'i686' 'x86_64' )
url="https://github.com/psypanda/hashID"
license=( 'GPL3' )
depends=( 'python' 'python2' )
-makedepends=( ''python-distribute'' ''python2-distribute'' ''python'' ''python2'' )
+makedepends=('python-distribute' 'python2-distribute' 'python' 'python2' 'python-setuptools' 'python2-setuptools')
_pkgname="hashID"
install=
changelog=
@@ -20,6 +20,9 @@ source=("https://files.pythonhosted.org/packages/source/h/${_pkgname}/${_pkgname
sha512sums=('598538454578cf71872950d43aab9fa8d274983646e2dc94462e5d3dcb0bee04c923cf8f6769cf5aa1a9d0e825c97cfa2560a11beebf1aeccc40648c90d03567'
'SKIP')
+# TODO: use the github zip instead?
+# that way we can package the man page.
+
package_python-hashid() {
depends=('python')
cd "${srcdir}/${_pkgname}-${pkgver}"