summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2016-06-14 12:18:48 +0800
committerYen Chi Hsuan2016-06-14 12:18:48 +0800
commit46147432cc72bc0a5da70cbea07f26deee34c03d (patch)
tree0f4e762670598a3ba2eac07b4a2a8b2d71263c7e
parent82f5effe37115d2e3b39ad811a86e84c34ad2ccb (diff)
downloadaur-46147432cc72bc0a5da70cbea07f26deee34c03d.tar.gz
add openssl as depends
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD12
3 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d20bf6f59c60..a52405baedb9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Tue Jun 14 04:18:34 UTC 2016
pkgbase = python-hashpumpy-git
pkgdesc = A tool to exploit the hash length extension attack in various hashing algorithms
- pkgver = v1.2.0.r2.g484c538
+ pkgver = v1.2.0.r4.g2d01d3b
pkgrel = 1
url = https://github.com/bwall/HashPump
arch = i686
@@ -8,6 +10,7 @@ pkgbase = python-hashpumpy-git
license = MIT
makedepends = git
depends = openssl
+ depends = python
provides = python-hashpumpy
source = python-hashpumpy::git+https://github.com/bwall/HashPump
md5sums = SKIP
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f7c1169a1d2a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+/python-hashpumpy
diff --git a/PKGBUILD b/PKGBUILD
index d620d698b40f..9b273575f04c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,16 @@
_pkgname=python-hashpumpy
pkgname=$_pkgname-git
-_github_addr=bwall/HashPump
-pkgver=v1.2.0.r2.g484c538
+pkgver=v1.2.0.r4.g2d01d3b
pkgrel=1
pkgdesc=" A tool to exploit the hash length extension attack in various hashing algorithms"
arch=("i686" "x86_64")
-url="https://github.com/$_github_addr"
+url="https://github.com/bwall/HashPump"
license=('MIT')
makedepends=('git')
-depends=('openssl')
+depends=('openssl' 'python')
provides=("$_pkgname")
-source=("$_pkgname"::"git+https://github.com/$_github_addr")
+source=("$_pkgname"::"git+https://github.com/bwall/HashPump")
md5sums=('SKIP')
pkgver() {
@@ -28,5 +27,8 @@ build() {
package() {
cd "${srcdir}/${_pkgname}"
python setup.py install --skip-build --root="${pkgdir}"
+
+ install -Dm755 -d "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 LICENSE.TXT "$pkgdir/usr/share/licenses/$pkgname/"
}