summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2015-06-08 18:29:47 +0800
committerYen Chi Hsuan2015-06-08 18:29:47 +0800
commit82f5effe37115d2e3b39ad811a86e84c34ad2ccb (patch)
tree4760ebe934a8f134acfb9a18c8ac4df6f2cb94b9
downloadaur-82f5effe37115d2e3b39ad811a86e84c34ad2ccb.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d20bf6f59c60
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-hashpumpy-git
+ pkgdesc = A tool to exploit the hash length extension attack in various hashing algorithms
+ pkgver = v1.2.0.r2.g484c538
+ pkgrel = 1
+ url = https://github.com/bwall/HashPump
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = openssl
+ provides = python-hashpumpy
+ source = python-hashpumpy::git+https://github.com/bwall/HashPump
+ md5sums = SKIP
+
+pkgname = python-hashpumpy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d620d698b40f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Yen Chi Hsuan <yan12125 at gmail dot com>
+
+_pkgname=python-hashpumpy
+pkgname=$_pkgname-git
+_github_addr=bwall/HashPump
+pkgver=v1.2.0.r2.g484c538
+pkgrel=1
+pkgdesc=" A tool to exploit the hash length extension attack in various hashing algorithms"
+arch=("i686" "x86_64")
+url="https://github.com/$_github_addr"
+license=('MIT')
+makedepends=('git')
+depends=('openssl')
+provides=("$_pkgname")
+source=("$_pkgname"::"git+https://github.com/$_github_addr")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ python setup.py install --skip-build --root="${pkgdir}"
+}
+