summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaizhao Zhang2019-10-20 17:30:14 +0800
committerKaizhao Zhang2019-10-20 17:30:14 +0800
commit6c88d2d798bb35150c514363d8c2b21e7dbc6028 (patch)
treeffb5c075fd1b93864a7c8bb2a16f3f6cbdf97cdb
parent379bcd6b34d33512510f97b0a58e1057693e11e5 (diff)
downloadaur-6c88d2d798bb35150c514363d8c2b21e7dbc6028.tar.gz
Updated to version 0.20.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD30
-rw-r--r--no-adduserpath-now.patch10
3 files changed, 33 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e196156fc2a9..aed54afdee7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = python-hatch
pkgdesc = A modern project, package, and virtual env manager
- pkgver = 0.11.0
- pkgrel = 3
+ pkgver = 0.20.0
+ pkgrel = 1
url = https://github.com/ofek/hatch
arch = any
license = MIT
license = APACHE
+ depends = python>=3.6
depends = python-appdirs
depends = python-atomicwrites
depends = python-click
@@ -16,7 +17,6 @@ pkgbase = python-hatch
depends = python-pytest
depends = python-semver>=2.7.8
depends = python-setuptools>=36.0.0
- depends = python-sortedcontainers>=1.5.7
depends = python-toml>=0.9.3
depends = twine>=1.9.1
depends = python-userpath>=1.1.0
@@ -24,10 +24,12 @@ pkgbase = python-hatch
depends = python-wheel>=0.27.0
provides = python-hatch
options = !emptydirs
- source = https://github.com/ofek/hatch/archive/0.11.0.tar.gz
+ source = https://files.pythonhosted.org/packages/source/h/hatch/hatch-0.20.0.tar.gz
+ source = no-adduserpath-now.patch
source = hatch_complete.sh
source = hatch_complete.zsh
- sha256sums = 89eb2417503125919f5536b0c50390affa2536b193ddcfc826ad96a4d17e7678
+ sha256sums = dddbc0e141dfcdc69f3c632515469b44d8610674abc52558d96dd4b7a9fa1382
+ sha256sums = 88999bb69dfcff6221a705b8383c793e757483dff2b7b002bd7b9c0abbe3c3c5
sha256sums = b87254c621719188907a2062b0aa3c4eb078088872d1de7d53d6a6d61a679c44
sha256sums = a43679d72ebb7b5c029192519597eff835586d0b6ed9d1e3dfc93270b8720e71
diff --git a/PKGBUILD b/PKGBUILD
index a8098005fdc7..97cc176da5be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,17 @@
# Maintainer: Kaizhao Zhang <zhangkaizhao@gmail.com>
-_srcname=hatch
+_name=hatch
+_sha256sum=dddbc0e141dfcdc69f3c632515469b44d8610674abc52558d96dd4b7a9fa1382
pkgname=python-hatch
-pkgver=0.11.0
-pkgrel=3
+pkgver=0.20.0
+pkgrel=1
pkgdesc="A modern project, package, and virtual env manager"
arch=('any')
url="https://github.com/ofek/hatch"
license=('MIT' 'APACHE')
depends=(
+ 'python>=3.6'
'python-appdirs'
'python-atomicwrites'
'python-click'
@@ -20,7 +22,6 @@ depends=(
'python-pytest'
'python-semver>=2.7.8'
'python-setuptools>=36.0.0'
- 'python-sortedcontainers>=1.5.7'
'python-toml>=0.9.3'
'twine>=1.9.1'
'python-userpath>=1.1.0'
@@ -30,33 +31,34 @@ depends=(
provides=('python-hatch')
options=(!emptydirs)
source=(
- "https://github.com/ofek/hatch/archive/${pkgver}.tar.gz"
+ "https://files.pythonhosted.org/packages/source/${_name:0:1}/${_name}/${_name}-${pkgver}.tar.gz"
+ 'no-adduserpath-now.patch'
'hatch_complete.sh'
'hatch_complete.zsh'
)
sha256sums=(
- '89eb2417503125919f5536b0c50390affa2536b193ddcfc826ad96a4d17e7678'
+ "${_sha256sum}"
+ '88999bb69dfcff6221a705b8383c793e757483dff2b7b002bd7b9c0abbe3c3c5'
'b87254c621719188907a2062b0aa3c4eb078088872d1de7d53d6a6d61a679c44'
'a43679d72ebb7b5c029192519597eff835586d0b6ed9d1e3dfc93270b8720e71'
)
prepare() {
- cd "${srcdir}/${_srcname}-${pkgver}"
+ cd "${srcdir}/${_name}-${pkgver}"
+ patch -p0 -i ../no-adduserpath-now.patch
+
# no need to include tests files
rm tests/__init__.py
}
build() {
- cd "${srcdir}/${_srcname}-${pkgver}"
+ cd "${srcdir}/${_name}-${pkgver}"
python setup.py build
}
package() {
- cd "${srcdir}/${_srcname}-${pkgver}"
+ cd "${srcdir}/${_name}-${pkgver}"
python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
- install -Dm644 COMMANDS.rst "${pkgdir}/usr/share/doc/${pkgname}/COMMANDS.rst"
- install -Dm644 CONFIG.rst "${pkgdir}/usr/share/doc/${pkgname}/CONFIG.rst"
- install -Dm644 HISTORY.rst "${pkgdir}/usr/share/doc/${pkgname}/HISTORY.rst"
install -Dm644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README.rst"
install -Dm644 LICENSE-MIT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-MIT"
install -Dm644 LICENSE-APACHE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-APACHE"
@@ -68,9 +70,9 @@ package() {
# Tab completion for Bash.
# Generated by `_HATCH_COMPLETE=source hatch > hatch_complete.sh`
- install -Dm644 hatch_complete.sh "${pkgdir}/usr/share/bash-completion/completions/${_srcname}"
+ install -Dm644 hatch_complete.sh "${pkgdir}/usr/share/bash-completion/completions/${_name}"
# Tab completion for Zsh.
# Generated by `_HATCH_COMPLETE=source_zsh hatch > hatch_complete.zsh`
- install -Dm644 hatch_complete.zsh "${pkgdir}/usr/share/zsh/site-functions/_${_srcname}"
+ install -Dm644 hatch_complete.zsh "${pkgdir}/usr/share/zsh/site-functions/_${_name}"
}
diff --git a/no-adduserpath-now.patch b/no-adduserpath-now.patch
new file mode 100644
index 000000000000..ad8a15c2653b
--- /dev/null
+++ b/no-adduserpath-now.patch
@@ -0,0 +1,10 @@
+--- setup.py.orig 2019-10-20 17:15:00.730064609 +0800
++++ setup.py 2019-10-20 17:15:07.896906249 +0800
+@@ -52,7 +52,6 @@
+ ),
+
+ install_requires=(
+- 'adduserpath>=0.4.0',
+ 'appdirs',
+ 'atomicwrites',
+ 'click',