summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Armengol2022-11-29 11:52:52 +0000
committerPatrick Armengol2022-11-29 11:52:52 +0000
commit6a217a1f92dc204594f71e21e621dd8103aa05e1 (patch)
tree0f0c2f8c5af95e457f7f8107f64a4616a80ec7f2
parentd8cecb655330932d36b57344c2d161d9e8db98c1 (diff)
downloadaur-6a217a1f92dc204594f71e21e621dd8103aa05e1.tar.gz
upgpkg: python-hatchling-git v1.11.1.r43.g15a583af-1
new package hatchling-git
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd7da1c33ea1..8872d1a7a9dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@ pkgbase = python-hatchling-git
pkgdesc = Modern, extensible Python build backend
pkgver = v1.11.1.r43.g15a583af
pkgrel = 1
- url = https://github.com/pypa/hatch
+ url = https://hatch.pypa.io/latest/
arch = any
license = MIT
checkdepends = python-pytest
@@ -16,6 +16,7 @@ pkgbase = python-hatchling-git
depends = python-pluggy
depends = python-tomli
provides = python-hatchling
+ conflicts = python-hatchling
source = hatch::git+https://github.com/pypa/hatch.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index e3ec0085fea7..f9726900e1e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgver=v1.11.1.r43.g15a583af
pkgrel=1
pkgdesc="Modern, extensible Python build backend"
arch=('any')
-url="https://github.com/pypa/hatch"
+url="https://hatch.pypa.io/latest/"
license=('MIT')
groups=()
depends=('python-editables' 'python-packaging' 'python-pathspec' 'python-pluggy' 'python-tomli')
@@ -14,13 +14,13 @@ makedepends=('git' 'python-build' 'python-installer' 'python-wheel')
checkdepends=('python-pytest')
optdepends=()
provides=('python-hatchling')
-conflicts=()
+conflicts=('python-hatchling') # the python-hatchling community package is missing a provides
replaces=()
backup=()
options=()
install=
changelog=
-source=("hatch::git+$url.git") # just download the whole thing lmao
+source=("hatch::git+https://github.com/pypa/hatch.git") # just download the whole thing lmao
# source=("svn+$url/trunk/backend") # depends on svn instead of git
noextract=()
sha256sums=('SKIP')
@@ -35,6 +35,7 @@ build() {
python -m build --wheel --no-isolation
}
+# tests are not found, issue #329 tracking
# check() {
# cd "hatch/backend"
# PYTHONPATH="$PWD/src" pytest