summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Shpilkin2019-05-19 12:41:41 +0300
committerAlexander Shpilkin2019-05-19 12:41:41 +0300
commit42ef0f15c2c416b240f7bb541e88ab1ed70966d1 (patch)
treefca9b38b3491696d0727adf3b8082a67ec2ed2db
parentd4ba5703caa51d178475fdba150e4582a686f071 (diff)
downloadaur-42ef0f15c2c416b240f7bb541e88ab1ed70966d1.tar.gz
Put name of package into _name
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5540be98fe46..890acb8a1c04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Maintainer: Alexander Shpilkin <ashpilkin@gmail.com>
-pkgname=python-hattifnatt
+_name=hattifnatt
+pkgname=python-${_name}
pkgver=0.2.1
pkgrel=1
pkgdesc="Push directory to Telegram channel"
-url="https://github.com/alexshpilkin/hattifnatt"
+url="https://github.com/alexshpilkin/${_name}"
arch=('any')
license=('custom:CC0')
depends=('python>=3.5'
@@ -12,19 +13,19 @@ depends=('python>=3.5'
'python-telegram-bot>=10.0.2'
'python-watchdog>=0.9.0')
makedepends=('python-setuptools')
-source=("https://github.com/alexshpilkin/hattifnatt/releases/download/v$pkgver/hattifnatt-$pkgver.tar.gz"
- "https://github.com/alexshpilkin/hattifnatt/releases/download/v$pkgver/hattifnatt-$pkgver.tar.gz.asc")
+source=("https://github.com/alexshpilkin/${_name}/releases/download/v$pkgver/${_name}-$pkgver.tar.gz"
+ "https://github.com/alexshpilkin/${_name}/releases/download/v$pkgver/${_name}-$pkgver.tar.gz.asc")
sha256sums=('4f10ff1f1e29590ce4bc25c7bbeecb5778bf4732118294543f0632cdc9139830'
'SKIP')
validpgpkeys=('B595D74D6615C010469F5A1373E9AA114B3A894B')
build() {
- cd "hattifnatt-$pkgver"
+ cd "${_name}-$pkgver"
python setup.py build
}
package() {
- cd "hattifnatt-$pkgver"
+ cd "${_name}-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}