summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrew DeVault2017-01-19 14:00:46 -0500
committerDrew DeVault2017-01-19 14:01:11 -0500
commitdbc33934975e78119d16f21d8a47fcab39eb344f (patch)
treeed7b9a1a2125539f7084c08704b56183e06ad95f
downloadaur-dbc33934975e78119d16f21d8a47fcab39eb344f.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d8c2bc7aae57
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Thu Jan 19 19:01:03 UTC 2017
+pkgbase = python-haxor
+ pkgdesc = Python wrapper for the Hacker News API
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/pycrypto
+ arch = any
+ license = MIT
+ makedepends = python-distribute
+ depends = python-requests
+ source = http://pypi.python.org/packages/source/h/haxor/haxor-0.3.1.tar.gz
+ md5sums = 291b679fc95d14d75cfd08f0818c024d
+
+pkgname = python-haxor
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0a2223f3641d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e8223564b91
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+pkgname="python-haxor"
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="Python wrapper for the Hacker News API"
+arch=("any")
+url="https://pypi.python.org/pypi/pycrypto"
+license=("MIT")
+depends=("python-requests")
+makedepends=("python-distribute")
+source=("http://pypi.python.org/packages/source/h/haxor/haxor-${pkgver}.tar.gz")
+md5sums=('291b679fc95d14d75cfd08f0818c024d')
+
+build() {
+ cd "${srcdir}/haxor-${pkgver}"
+ python ./setup.py build
+}
+
+package() {
+ cd "${srcdir}/haxor-${pkgver}"
+ python setup.py install --root="$pkgdir" --optimize=1
+}