summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrew DeVault2019-02-25 11:15:30 -0500
committerDrew DeVault2019-02-25 11:15:30 -0500
commitf80bbb17549ad0363b6172e1d2ebbec1761b5d32 (patch)
tree99e57909ae7c9326e51e46a9bb954f95785b6a20
parentdbc33934975e78119d16f21d8a47fcab39eb344f (diff)
downloadaur-f80bbb17549ad0363b6172e1d2ebbec1761b5d32.tar.gz
Update to 1.2.1; clean up PKGBUILD
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
2 files changed, 19 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8c2bc7aae57..63c32e9c311c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
-# Generated by mksrcinfo v8
-# Thu Jan 19 19:01:03 UTC 2017
pkgbase = python-haxor
pkgdesc = Python wrapper for the Hacker News API
- pkgver = 0.3.1
+ pkgver = 1.2.1
pkgrel = 1
- url = https://pypi.python.org/pypi/pycrypto
+ url = https://pypi.org/project/haxor
arch = any
license = MIT
- makedepends = python-distribute
+ makedepends = python-setuptools
depends = python-requests
- source = http://pypi.python.org/packages/source/h/haxor/haxor-0.3.1.tar.gz
- md5sums = 291b679fc95d14d75cfd08f0818c024d
+ source = python-haxor-1.2.1.tar.gz::https://files.pythonhosted.org/packages/source/h/haxor/haxor-1.2.1.tar.gz
+ sha256sums = a4341c3f4beb5ba797767af902378b24052bbb6be9e77552b7a9e56ec2002d5e
pkgname = python-haxor
diff --git a/PKGBUILD b/PKGBUILD
index 1e8223564b91..bdbc5638d095 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,29 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname="python-haxor"
-pkgver=0.3.1
+_pkgname="haxor"
+pkgver=1.2.1
pkgrel=1
pkgdesc="Python wrapper for the Hacker News API"
arch=("any")
-url="https://pypi.python.org/pypi/pycrypto"
+url="https://pypi.org/project/haxor"
license=("MIT")
depends=("python-requests")
-makedepends=("python-distribute")
-source=("http://pypi.python.org/packages/source/h/haxor/haxor-${pkgver}.tar.gz")
-md5sums=('291b679fc95d14d75cfd08f0818c024d')
+makedepends=("python-setuptools")
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('a4341c3f4beb5ba797767af902378b24052bbb6be9e77552b7a9e56ec2002d5e')
build() {
- cd "${srcdir}/haxor-${pkgver}"
+ cd "$_pkgname-$pkgver"
python ./setup.py build
}
+# Upstream test suite segfaults...
+#check() {
+# cd "$_pkgname-$pkgver"
+# python ./setup.py test
+#}
+
package() {
- cd "${srcdir}/haxor-${pkgver}"
+ cd "$_pkgname-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
}