summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjerry732042018-12-07 10:12:28 +0800
committerjerry732042018-12-07 10:12:28 +0800
commita314e5415e44d4b04c67e8b5495502d0850f4fbe (patch)
tree4b4a8957318f8ece0c28840e04b81bd0d479758a
downloadaur-a314e5415e44d4b04c67e8b5495502d0850f4fbe.tar.gz
Upload version 0.9.5-1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD26
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c5c6227773d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-hbmqtt
+ pkgdesc = Python client for Apache Kafka
+ pkgver = 0.9.5
+ pkgrel = 1
+ url = https://github.com/mikeboers/PyAV/tree/master
+ arch = x86_64
+ license = Apache
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ depends = python-transitions
+ depends = python-websockets
+ depends = python-passlib
+ depends = python-docopt
+ depends = python-pyyaml
+ source = https://github.com/beerfactory/hbmqtt/archive/0.9.5.tar.gz
+ sha256sums = 8afe70008fbe213ae9aff6d66d6db845b41b36d9f89f711657478ec3aa428790
+
+pkgname = python-hbmqtt
+ depends = python
+ depends = hbmqtt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..671758163467
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jerry Lin <jerry73204 at gmail dot com>
+
+pkgname=('python-hbmqtt')
+pkgver=0.9.5
+pkgrel=1
+pkgdesc='Python client for Apache Kafka'
+arch=('x86_64')
+url="https://github.com/mikeboers/PyAV/tree/master"
+license=('Apache')
+makedepends=('python-setuptools' 'python2-setuptools')
+depends=('python-transitions' 'python-websockets' 'python-passlib' 'python-docopt' 'python-pyyaml')
+source=("https://github.com/beerfactory/hbmqtt/archive/${pkgver}.tar.gz")
+sha256sums=('8afe70008fbe213ae9aff6d66d6db845b41b36d9f89f711657478ec3aa428790')
+
+_dirname="hbmqtt-${pkgver}"
+
+build() {
+ cd "${srcdir}/${_dirname}"
+ python setup.py build
+}
+
+package() {
+ depends=('python' 'hbmqtt')
+ cd "${srcdir}/${_dirname}"
+ python setup.py install --root="$pkgdir" --optimize=1
+}