summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-03-09 14:45:28 +0100
committerGrey Christoforo2019-03-09 14:45:28 +0100
commitff4906325a74742ccfaa01938efb5bbba15015a2 (patch)
treea2f06a359d44fb88e4e6c13e93e2fae4d47d0972
downloadaur-ff4906325a74742ccfaa01938efb5bbba15015a2.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD24
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..00439381ce05
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-hdmedians
+ pkgdesc = High-dimensional medians
+ pkgver = 0.13
+ pkgrel = 1
+ url = http://github.com/daleroberts/hdmedians
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/h/hdmedians/hdmedians-0.13.tar.gz
+ md5sums = 27945c64fd9ba1a46ef6c136d402291d
+
+pkgname = python-hdmedians
+ depends = python
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72a3ed3fe6e0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9715166db59a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgbase=('python-hdmedians')
+pkgname=('python-hdmedians')
+_module='hdmedians'
+pkgver='0.13'
+pkgrel=1
+pkgdesc="High-dimensional medians"
+url="http://github.com/daleroberts/hdmedians"
+depends=('python')
+makedepends=('python-setuptools')
+license=('GPL3')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/h/hdmedians/hdmedians-${pkgver}.tar.gz")
+md5sums=('27945c64fd9ba1a46ef6c136d402291d')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}