summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2023-02-10 15:48:49 +0800
committerUniversebenzene2023-02-10 15:48:49 +0800
commit57c2d108da8291b580b99434a832f96fbdac695f (patch)
tree95100e54b3ae4a2b5f974bcd9919aefdaba8d92f
parent04cbf58a9e73e313c9d028531c50b89975ee2897 (diff)
downloadaur-57c2d108da8291b580b99434a832f96fbdac695f.tar.gz
Update to version 1.16.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07b3af9994ad..b577428ca7c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-healpy
pkgdesc = Python package to manipulate healpix maps
- pkgver = 1.16.1
+ pkgver = 1.16.2
pkgrel = 1
url = http://healpy.readthedocs.io
arch = i686
@@ -22,7 +22,7 @@ pkgbase = python-healpy
depends = cfitsio>=4.1.0
depends = healpix>=3.80
optdepends = python-healpy-doc: Documentation for healpy
- source = https://files.pythonhosted.org/packages/source/h/healpy/healpy-1.16.1.tar.gz
- md5sums = e5993b888192847eee9b622bb3b06f51
+ source = https://files.pythonhosted.org/packages/source/h/healpy/healpy-1.16.2.tar.gz
+ md5sums = ff3015917f100cd7ff058220a7c088c4
pkgname = python-healpy
diff --git a/PKGBUILD b/PKGBUILD
index d4d634bf3d9a..4333d32ca0b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-healpy
_pyname=${pkgname#python-}
-pkgver=1.16.1
+pkgver=1.16.2
pkgrel=1
pkgdesc="Python package to manipulate healpix maps"
arch=('i686' 'x86_64')
@@ -17,7 +17,7 @@ makedepends=('python-setuptools'
optdepends=('python-healpy-doc: Documentation for healpy')
checkdepends=('python-pytest-cython' 'python-pytest-doctestplus' 'python-requests')
source=("https://files.pythonhosted.org/packages/source/h/healpy/healpy-${pkgver}.tar.gz")
-md5sums=('e5993b888192847eee9b622bb3b06f51')
+md5sums=('ff3015917f100cd7ff058220a7c088c4')
get_pyver() {
python -c "import sys; print('$1'.join(map(str, sys.version_info[:2])))"
@@ -39,12 +39,12 @@ check() {
cd ${srcdir}/${_pyname}-${pkgver}
# skip tests that cost lots of time
- pytest "build/lib.linux-${CARCH}-cpython-$(get_pyver)" \
- --deselect=build/lib.linux-${CARCH}-cpython-$(get_pyver)/healpy/test/test_pixelweights.py::test_pixelweights_local_datapath || warning "Tests failed"
+ pytest "build/lib.linux-${CARCH}-cpython-$(get_pyver)" || warning "Tests failed" # -vv --color=yes \
+# --deselect=build/lib.linux-${CARCH}-cpython-$(get_pyver)/healpy/test/test_pixelweights.py::test_pixelweights_local_datapath || warning "Tests failed"
}
package() {
- cd ${srcdir}/healpy-${pkgver}
+ cd ${srcdir}/${_pyname}-${pkgver}
install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
python -m installer --destdir="${pkgdir}" dist/*.whl