summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2022-07-18 13:07:23 +0800
committerUniversebenzene2022-07-18 13:07:23 +0800
commit5f87031ce2b7e3b356fff62a11ab024a4c4c9f3c (patch)
tree470034b515d38395d5ce89e4a6733d4f44c4b865
parent6dcfe4f48a9d9449fd5c86632cf4991c24d5b6e1 (diff)
downloadaur-5f87031ce2b7e3b356fff62a11ab024a4c4c9f3c.tar.gz
Update to version 1.16.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 19 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef6a4d134014..05ffde734584 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-healpy
pkgdesc = Python package to manipulate healpix maps
- pkgver = 1.15.2
+ pkgver = 1.16.0
pkgrel = 1
url = http://healpy.readthedocs.io
arch = i686
@@ -9,11 +9,11 @@ pkgbase = python-healpy
checkdepends = python-pytest-cython
checkdepends = python-pytest-doctestplus
checkdepends = python-requests
+ makedepends = python-setuptools
makedepends = cython
makedepends = python-wheel
makedepends = python-build
makedepends = python-installer
- makedepends = python-oldest-supported-numpy
depends = python>=3.7
depends = python-numpy>=1.13
depends = python-scipy
@@ -22,7 +22,7 @@ pkgbase = python-healpy
depends = cfitsio
depends = healpix>=3.80
optdepends = python-healpy-doc: Documentation for healpy
- source = https://files.pythonhosted.org/packages/source/h/healpy/healpy-1.15.2.tar.gz
- md5sums = e9518a20effe71de73c7195ce023e76e
+ source = https://files.pythonhosted.org/packages/source/h/healpy/healpy-1.16.0.tar.gz
+ md5sums = 2a386129ccad6469d5a3398d0b920923
pkgname = python-healpy
diff --git a/PKGBUILD b/PKGBUILD
index 6efa95b9cb95..9110dcb9c378 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,31 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgname=python-healpy
_pyname=${pkgname#python-}
-pkgver=1.15.2
+pkgver=1.16.0
pkgrel=1
pkgdesc="Python package to manipulate healpix maps"
arch=('i686' 'x86_64')
url="http://healpy.readthedocs.io"
license=('GPL')
depends=('python>=3.7' 'python-numpy>=1.13' 'python-scipy' 'python-matplotlib' 'python-astropy' 'cfitsio' 'healpix>=3.80')
-makedepends=('cython' 'python-wheel' 'python-build' 'python-installer' 'python-oldest-supported-numpy')
+makedepends=('python-setuptools'
+ 'cython'
+ 'python-wheel'
+ 'python-build'
+ 'python-installer')
optdepends=('python-healpy-doc: Documentation for healpy')
checkdepends=('python-pytest-cython' 'python-pytest-doctestplus' 'python-requests')
source=("https://files.pythonhosted.org/packages/source/h/healpy/healpy-${pkgver}.tar.gz")
-md5sums=('e9518a20effe71de73c7195ce023e76e')
+md5sums=('2a386129ccad6469d5a3398d0b920923')
+
+get_pyver() {
+ python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))'
+}
prepare() {
- export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ sed -i -e "/oldest-supported-numpy/d" -e "/\"wheel\"/s/,/\]/" pyproject.toml
}
build() {
@@ -28,7 +38,7 @@ check() {
cd ${srcdir}/${_pyname}-${pkgver}
# skip tests that cost lots of time
- pytest "build/lib.linux-${CARCH}-${_pyver}" \
+ pytest "build/lib.linux-${CARCH}-$(get_pyver)" \
--deselect=build/lib.linux-x86_64-3.10/healpy/test/test_pixelweights.py::test_pixelweights_local_datapath || warning "Tests failed"
}