summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2018-02-02 15:29:23 +0800
committerUniversebenzene2018-02-02 15:29:23 +0800
commit93b75ec996e928f177e2bf7ecb0b87bbf64d5036 (patch)
tree67a6dfbaaa1c6cb75c185362ac15879753c67249
downloadaur-93b75ec996e928f177e2bf7ecb0b87bbf64d5036.tar.gz
Initial import 1.11.0
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD18
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..44eb6e422596
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Feb 2 07:28:37 UTC 2018
+pkgbase = python-healpy
+ pkgdesc = Python package to manipulate healpix maps
+ pkgver = 1.11.0
+ pkgrel = 1
+ url = http://healpy.readthedocs.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python>=3.4
+ depends = python-numpy>=1.5
+ depends = python-matplotlib
+ depends = python-astropy
+ source = https://files.pythonhosted.org/packages/source/h/healpy/healpy-1.11.0.tar.gz
+ md5sums = c30daf225b3173224d6ea0cb10714b87
+
+pkgname = python-healpy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9eb013a61c3b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+pkgname=python-healpy
+pkgver=1.11.0
+pkgrel=1
+pkgdesc="Python package to manipulate healpix maps"
+arch=('i686' 'x86_64')
+url="http://healpy.readthedocs.org"
+license=('GPL')
+depends=('python>=3.4' 'python-numpy>=1.5' 'python-matplotlib' 'python-astropy')
+source=("https://files.pythonhosted.org/packages/source/h/healpy/healpy-${pkgver}.tar.gz")
+md5sums=('c30daf225b3173224d6ea0cb10714b87')
+
+package() {
+ cd ${srcdir}/healpy-${pkgver}
+
+ install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+}