summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2021-06-23 00:22:15 +0800
committerUniversebenzene2021-06-23 00:22:15 +0800
commitda9d19534c25b1c3d85c15b449f885db4ae294d6 (patch)
tree9f0cbbc1ddf8acc2a97b8916469e72ca23e397ca
parent770f7316dda3127825ded7087c8a3a3e96cc4c75 (diff)
downloadaur-da9d19534c25b1c3d85c15b449f885db4ae294d6.tar.gz
Update to version 1.15.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f533926de1c..e6a67afbb8fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-healpy
pkgdesc = Python package to manipulate healpix maps
- pkgver = 1.14.0
+ pkgver = 1.15.0
pkgrel = 1
url = http://healpy.readthedocs.io
arch = i686
@@ -12,16 +12,16 @@ pkgbase = python-healpy
checkdepends = python-requests
makedepends = cython>=0.16
makedepends = python-pytest-runner
- depends = python>=3.4
+ depends = python>=3.6
depends = python-numpy>=1.13
+ depends = python-scipy
depends = python-matplotlib
depends = python-astropy
depends = cfitsio
depends = healpix>=3.60
depends = python-six
optdepends = python-healpy-doc: Documentation for healpy
- source = https://files.pythonhosted.org/packages/source/h/healpy/healpy-1.14.0.tar.gz
- md5sums = 2e56fdad5fa3780f7381449a7b2672fb
+ source = https://files.pythonhosted.org/packages/source/h/healpy/healpy-1.15.0.tar.gz
+ md5sums = f0fc4e0a818fae18d349b66b05c7b178
pkgname = python-healpy
-
diff --git a/PKGBUILD b/PKGBUILD
index ac16b7ad666f..aea963c88772 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgname=python-healpy
_pyname=${pkgname#python-}
-pkgver=1.14.0
+pkgver=1.15.0
pkgrel=1
pkgdesc="Python package to manipulate healpix maps"
arch=('i686' 'x86_64')
url="http://healpy.readthedocs.io"
license=('GPL')
-depends=('python>=3.4' 'python-numpy>=1.13' 'python-matplotlib' 'python-astropy' 'cfitsio' 'healpix>=3.60' 'python-six')
+depends=('python>=3.6' 'python-numpy>=1.13' 'python-scipy' 'python-matplotlib' 'python-astropy' 'cfitsio' 'healpix>=3.60' 'python-six')
makedepends=('cython>=0.16' 'python-pytest-runner')
optdepends=('python-healpy-doc: Documentation for healpy')
checkdepends=('python-pytest-cython' 'python-pytest-doctestplus' 'python-pillow' 'python-requests')
source=("https://files.pythonhosted.org/packages/source/h/healpy/healpy-${pkgver}.tar.gz")
-md5sums=('2e56fdad5fa3780f7381449a7b2672fb')
+md5sums=('f0fc4e0a818fae18d349b66b05c7b178')
prepare() {
export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')