summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2019-03-23 11:33:15 +0800
committerUniversebenzene2019-03-23 11:33:15 +0800
commit2dd1a6603951b1d83bfc8b7deec78c017dc41a5b (patch)
tree43da7424dd7771f8aa4f0f21a18b17486f72a229
downloadaur-2dd1a6603951b1d83bfc8b7deec78c017dc41a5b.tar.gz
Initial import 1.12.9
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
-rw-r--r--fix_underline_warning.patch32
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..885f12f42fe5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sat Mar 23 03:31:35 UTC 2019
+pkgbase = python-healpy-doc
+ pkgdesc = Documentation for Python iminuit module
+ pkgver = 1.12.9
+ pkgrel = 1
+ url = http://healpy.readthedocs.io
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = python-healpy=1.12.9
+ makedepends = python-numpydoc
+ source = https://github.com/healpy/healpy/archive/1.12.9.tar.gz
+ source = fix_underline_warning.patch
+ md5sums = 2966c57f48c637611fe407fafa66f3b8
+ md5sums = d1fd09c9686b5eebdfbf06cd902e8575
+
+pkgname = python-healpy-doc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94778f2ea825
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+_pyname=healpy
+pkgname=python-${_pyname}-doc
+pkgver=1.12.9
+pkgrel=1
+pkgdesc="Documentation for Python iminuit module"
+arch=('i686' 'x86_64')
+url="http://healpy.readthedocs.io"
+license=('GPL')
+makedepends=("python-${_pyname}=${pkgver}" 'python-numpydoc')
+source=("https://github.com/healpy/healpy/archive/${pkgver}.tar.gz"
+ 'fix_underline_warning.patch')
+md5sums=('2966c57f48c637611fe407fafa66f3b8'
+ 'd1fd09c9686b5eebdfbf06cd902e8575')
+
+prepare() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ patch -Np1 -i "${srcdir}/fix_underline_warning.patch"
+}
+
+build() {
+ cd ${srcdir}/${_pyname}-${pkgver}/doc
+
+ make html
+}
+
+package() {
+ cd ${srcdir}/${_pyname}-${pkgver}/doc/.build
+
+ install -d -m755 "${pkgdir}/usr/share/doc/${pkgname%-doc}"
+ cp -a html "${pkgdir}/usr/share/doc/${pkgname%-doc}"
+}
diff --git a/fix_underline_warning.patch b/fix_underline_warning.patch
new file mode 100644
index 000000000000..d3b338c5d880
--- /dev/null
+++ b/fix_underline_warning.patch
@@ -0,0 +1,32 @@
+--- a/doc/healpy_zoomtool.rst 2019-03-22 05:51:07.000000000 +0800
++++ b/doc/healpy_zoomtool.rst 2019-03-23 11:08:47.898324511 +0800
+@@ -4,7 +4,7 @@
+
+
+ :mod:`zoomtool` -- Interactive visualisation
+-================================
++============================================
+
+ Interactive map visualization
+ -----------------------------
+diff -ura a/INSTALL.rst b/INSTALL.rst
+--- a/INSTALL.rst 2019-03-22 05:51:07.000000000 +0800
++++ b/INSTALL.rst 2019-03-23 11:09:21.075138156 +0800
+@@ -10,7 +10,7 @@
+ Only Linux and MAC OS X are supported, not Windows.
+
+ Binary installation with conda (RECOMMENDED)
+------------------------
++--------------------------------------------
+
+ Conda forge provides a `conda
+ channel <https://anaconda.org/conda-forge/healpy>`_ with a pre-compiled version of ``healpy``
+@@ -20,7 +20,7 @@
+ conda install healpy
+
+ Source installation with Pip
+----------------------------
++----------------------------
+
+ It is possible to build the latest ``healpy`` with `pip <http://www.pip-installer.org>`_ ::
+