summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2021-06-29 01:05:17 +0800
committerUniversebenzene2021-06-29 01:05:17 +0800
commite04a1aa931ec4bbc9f89c5c45cc39ab61b2b6e32 (patch)
treec97f6a7b124d4f26cee04601b5779f5267a0fac9
parent7a1449e32eadbd4c7eee47cfc18dbf5bdff89620 (diff)
downloadaur-e04a1aa931ec4bbc9f89c5c45cc39ab61b2b6e32.tar.gz
Update to version 0.15.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD11
-rw-r--r--fix_doc_warning.patch30
3 files changed, 15 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3a765b29f26..e01140db9462 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
pkgbase = python-healpy-doc
pkgdesc = Documentation for Python iminuit module
- pkgver = 1.14.0
+ pkgver = 1.15.0
pkgrel = 1
url = http://healpy.readthedocs.io
arch = i686
arch = x86_64
license = GPL
- makedepends = python-healpy=1.14.0
+ makedepends = python-healpy=1.15.0
makedepends = python-numpydoc
makedepends = python-pillow
- source = https://github.com/healpy/healpy/archive/1.14.0.tar.gz
+ makedepends = python-nbsphinx
+ makedepends = pandoc
+ makedepends = wget
+ makedepends = python-jinja<3.0.0
+ source = https://github.com/healpy/healpy/archive/1.15.0.tar.gz
source = fix_doc_warning.patch
- md5sums = 1d0aa0ee4599f7dc30933fedfafc713b
- md5sums = 685840f1c3333c81d00b9eea58aafc8e
+ md5sums = b7e683e33e23cc6640d8a1327af3b55f
+ md5sums = 564da1e5f36d3f48543086a233db6ab0
pkgname = python-healpy-doc
-
diff --git a/PKGBUILD b/PKGBUILD
index 7e32abad32b7..54ce12e60991 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,24 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
_pyname=healpy
pkgname=python-${_pyname}-doc
-pkgver=1.14.0
+pkgver=1.15.0
pkgrel=1
pkgdesc="Documentation for Python iminuit module"
arch=('i686' 'x86_64')
url="http://healpy.readthedocs.io"
license=('GPL')
-makedepends=("python-${_pyname}=${pkgver}" 'python-numpydoc' 'python-pillow')
+makedepends=("python-${_pyname}=${pkgver}" 'python-numpydoc' 'python-pillow' 'python-nbsphinx' 'pandoc' 'wget' 'python-jinja<3.0.0')
source=("https://github.com/healpy/healpy/archive/${pkgver}.tar.gz"
'fix_doc_warning.patch')
-md5sums=('1d0aa0ee4599f7dc30933fedfafc713b'
- '685840f1c3333c81d00b9eea58aafc8e')
+md5sums=('b7e683e33e23cc6640d8a1327af3b55f'
+ '564da1e5f36d3f48543086a233db6ab0')
prepare() {
cd ${srcdir}/${_pyname}-${pkgver}
patch -Np1 -i "${srcdir}/fix_doc_warning.patch"
+ sed -e "/^extensions/s/nbsphinx\"\]/nbsphinx\",\ \'IPython\.sphinxext\.ipython_console_highlighting\'\]/" \
+ -e "/^extension/a nbsphinx_allow_errors = True" -i doc/conf.py
}
build() {
@@ -30,5 +32,4 @@ package() {
install -d -m755 "${pkgdir}/usr/share/doc/${pkgname%-doc}"
cp -a html "${pkgdir}/usr/share/doc/${pkgname%-doc}"
- install -m644 ../healpy_tutorial.ipynb "${pkgdir}/usr/share/doc/${pkgname%-doc}"
}
diff --git a/fix_doc_warning.patch b/fix_doc_warning.patch
index 19390be07c44..ca40fe2db5fe 100644
--- a/fix_doc_warning.patch
+++ b/fix_doc_warning.patch
@@ -1,4 +1,3 @@
-diff -ura a/doc/healpy_zoomtool.rst b/doc/healpy_zoomtool.rst
--- a/doc/healpy_zoomtool.rst 2019-09-10 13:17:36.000000000 +0800
+++ b/doc/healpy_zoomtool.rst 2019-09-10 14:17:14.230737604 +0800
@@ -4,7 +4,7 @@
@@ -10,32 +9,3 @@ diff -ura a/doc/healpy_zoomtool.rst b/doc/healpy_zoomtool.rst
Interactive map visualization
-----------------------------
-diff -ura a/INSTALL.rst b/INSTALL.rst
---- a/INSTALL.rst 2019-09-10 13:17:36.000000000 +0800
-+++ b/INSTALL.rst 2019-09-10 14:16:27.437402127 +0800
-@@ -10,7 +10,7 @@
- Only Linux and MAC OS X are supported, not Windows.
-
- Binary installation with conda (RECOMMENDED)
-------------------------
-+--------------------------------------------
-
- Conda forge provides a `conda
- channel <https://anaconda.org/conda-forge/healpy>`_ with a pre-compiled version of ``healpy``
-@@ -20,7 +20,7 @@
- conda install healpy
-
- Source installation with Pip
-----------------------------
-+----------------------------
-
- It is possible to build the latest ``healpy`` with `pip <http://www.pip-installer.org>`_ ::
-
-@@ -73,6 +73,7 @@
- If everything goes fine, you can test it::
-
- python
-+
- >>> import matplotlib.pyplot as plt
- >>> import numpy as np
- >>> import healpy as hp