summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrazer2021-04-04 10:27:15 +0200
committerrazer2021-04-04 10:27:15 +0200
commit239cc75dc91260614ab445c89db0d3b8acc5fc8f (patch)
treefbcabcab216040f224f22a715b63aaa438b7f349
downloadaur-239cc75dc91260614ab445c89db0d3b8acc5fc8f.tar.gz
Initial release
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6a3aefcf813
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-heatshrink2
+ pkgdesc = Compression using the Heatshrink algorithm in Python 3
+ pkgver = 0.10.0
+ pkgrel = 0
+ url = https://github.com/eerimoq/pyheatshrink
+ arch = any
+ license = ISC
+ makedepends = python-setuptools
+ depends = python
+ source = https://pypi.io/packages/source/h/heatshrink2/heatshrink2-0.10.0.tar.gz
+ sha256sums = 11261cea2343cfd58c52a1457a909c5da680c0f983b0088234f4fe5016408694
+
+pkgname = python-heatshrink2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a22b2bff88be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Razer <razer[AT]neuf[DOT]fr>
+
+pkgname=python-heatshrink2
+_pypi_pkgname=heatshrink2
+pkgver=0.10.0
+pkgrel=0
+pkgdesc="Compression using the Heatshrink algorithm in Python 3"
+arch=(any)
+url="https://github.com/eerimoq/pyheatshrink"
+license=('ISC')
+makedepends=('python-setuptools')
+depends=('python')
+optdepends=()
+source=("https://pypi.io/packages/source/h/${_pypi_pkgname}/${_pypi_pkgname}-${pkgver}.tar.gz")
+sha256sums=('11261cea2343cfd58c52a1457a909c5da680c0f983b0088234f4fe5016408694')
+
+build() {
+ cd "${srcdir}/${_pypi_pkgname}-${pkgver}"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "${srcdir}/${_pypi_pkgname}-${pkgver}"
+ python setup.py install --root=${pkgdir} --optimize=1 || return 1
+}