summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUrbain Vaes2018-10-19 13:45:20 +0200
committerUrbain Vaes2018-10-19 13:45:20 +0200
commit9e3d832e19fdc400716fbb5108444dddf34b98ac (patch)
tree2843c4c98c9cf7800cd0475879d34a3443400217
downloadaur-9e3d832e19fdc400716fbb5108444dddf34b98ac.tar.gz
Add PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD31
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..599cdc0b2294
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-hermipy-git
+ pkgdesc = Library for the Hermite spectral method
+ pkgver = r580.627564d
+ pkgrel = 1
+ url = https://github.com/urbainvaes/hermipy
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = python-setuptools
+ makedepends = cmake
+ makedepends = make
+ makedepends = boost
+ makedepends = boost-libs
+ depends = python-sympy
+ depends = python-numpy
+ depends = python-scipy
+ source = git+https://github.com/urbainvaes/hermipy
+ md5sums = SKIP
+
+pkgname = python-hermipy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7ef74bbd6479
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Urbain Vaes <urbain at vaes dot uk>
+
+pkgname=python-hermipy-git
+_gitname=hermipy
+pkgver=r580.627564d
+pkgrel=1
+pkgdesc="Library for the Hermite spectral method"
+arch=(any)
+url="https://github.com/urbainvaes/hermipy"
+license=(GPL)
+makedepends=(git python-setuptools cmake make boost boost-libs)
+depends=(python-sympy python-numpy python-scipy)
+source=("git+https://github.com/urbainvaes/hermipy")
+md5sums=(SKIP)
+
+pkgver() {
+ cd $_gitname
+ commit=$(git rev-list --count master)
+ hash=$(git rev-parse --short HEAD)
+ echo "r$commit.$hash"
+}
+
+build() {
+ cd $_gitname
+ python setup.py build
+}
+
+package() {
+ cd $_gitname
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
+}