summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorButui Hu2019-11-17 10:31:27 +0800
committerButui Hu2019-11-17 10:31:27 +0800
commit86295afe5ab3bb2441ad8a23a23ea5b3d3c3b98d (patch)
tree3e8f1c770b72cae3f7f9518c413b27ef97c33630
parent23a4e3ff7156064ce0c5c014e5ee0e78481615e5 (diff)
downloadaur-86295afe5ab3bb2441ad8a23a23ea5b3d3c3b98d.tar.gz
update PKGBUILD
-rw-r--r--PKGBUILD30
1 files changed, 16 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 67fc4507c496..39553d378e8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,19 +5,21 @@ pkgname=python-hiddenlayer
pkgver=0.2
pkgrel=1
pkgdesc='A lightweight library for neural network graphs and training metrics for PyTorch, Tensorflow, and Keras'
-arch=(any)
-url=https://github.com/waleedka/hiddenlayer
-license=(MIT)
-makedepends=(python-setuptools)
-checkdepends=(flake8
- ipython
- python-matplotlib
- python-numpy
- python-pytest
- python-pytorch
- python-tensorflow
- python-torchvision)
-source=("${_pkgname}-${pkgver}.tar.gz"::"https://github.com/waleedka/hiddenlayer/archive/v${pkgver}.tar.gz")
+arch=('any')
+url='https://github.com/waleedka/hiddenlayer'
+license=('MIT')
+makedepends=('python-setuptools')
+checkdepends=(
+ 'flake8'
+ 'ipython'
+ 'python-matplotlib'
+ 'python-numpy'
+ 'python-pytest'
+ 'python-pytorch'
+ 'python-tensorflow'
+ 'python-torchvision'
+)
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/waleedka/hiddenlayer/archive/v${pkgver}.tar.gz")
sha512sums=('95291b6beaa1c131c9aa27d4e6b5b26e00548f4d34c69518fe38baac29c9d9d4f9c770f8339b1319cd54ffaa81895d46dfde17f25c9786ac91bdee2a6d653443')
build() {
@@ -27,7 +29,7 @@ build() {
check() {
cd "${_pkgname}-${pkgver}"
-# PYTHONPATH=. pytest -v
+ PYTHONPATH=${srcdir}/${_pkgname}-${pkgver}/build/lib pytest -v
}
package() {