summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Henrie2023-10-25 16:58:32 -0600
committerAlex Henrie2023-10-25 16:58:32 -0600
commit0f3ce253692a7e731b4bb9ab2847e6c3a4acd157 (patch)
treec2ff00a5cebec062cd6c302341ce12f49ee8ed88
downloadaur-0f3ce253692a7e731b4bb9ab2847e6c3a4acd157.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4b75867c416
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-hilbertcurve
+ pkgdesc = Converts between one-dimensional distance along a Hilbert curve and n-dimensional points
+ pkgver = 2.0.5
+ pkgrel = 1
+ url = https://github.com/galtay/hilbertcurve
+ arch = any
+ license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python-numpy
+ source = https://files.pythonhosted.org/packages/source/h/hilbertcurve/hilbertcurve-2.0.5.tar.gz
+ sha256sums = 6a7703d9a2f1fe748c86d86908bf183e7d139b973645e4b2526e10b34e75796d
+
+pkgname = python-hilbertcurve
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db093914dfa3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Alex Henrie <alexhenrie24@gmail.com>
+_name=hilbertcurve
+pkgname=python-$_name
+pkgver=2.0.5
+pkgrel=1
+pkgdesc='Converts between one-dimensional distance along a Hilbert curve and n-dimensional points'
+arch=('any')
+url='https://github.com/galtay/hilbertcurve'
+license=('MIT')
+depends=('python-numpy')
+makedepends=('python-build' 'python-installer' 'python-wheel')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('6a7703d9a2f1fe748c86d86908bf183e7d139b973645e4b2526e10b34e75796d')
+
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}