summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2024-03-11 11:47:09 +0200
committerAdrian Perez de Castro2024-03-11 11:47:09 +0200
commit0c2bba74c9974b022ca0b14d63904497fe1d8f07 (patch)
tree8f98039820fc529b69aeea2c83087e2404880fed
parent27e17e207663843e06cbc7ebede12aa0f3f064d7 (diff)
downloadaur-0c2bba74c9974b022ca0b14d63904497fe1d8f07.tar.gz
Bump to version 14
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD36
2 files changed, 22 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af4e40fedfb9..9914d531e76b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,17 @@
-# Generated by makepkg 5.0.0
-# Mon Feb 8 12:06:45 UTC 2016
pkgbase = python-hipack
pkgdesc = Python module for the HiPack serialization format
- pkgver = 12
+ pkgver = 14
pkgrel = 1
url = http://hipack.org
arch = any
- license = GPL3
+ license = GPL-3.0-only
license = MIT
- makedepends = python2-setuptools
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
- source = https://pypi.python.org/packages/source/h/hipack/hipack-12.tar.gz
- sha512sums = 958c85dd852bd36fe2bd21c5d24f67eb2276130fabd624afcc4264b522ce49b7955afc41dbdb666553fc9d9b5c5c5b14a821aece6c2c275d3aca86dfe031681b
-
-pkgname = python2-hipack
- depends =
- depends = python2
-
-pkgname = python-hipack
- depends =
+ makedepends = python-wheel
depends = python
+ source = https://github.com/aperezdc/hipack-python/releases/download/v14/hipack-14.tar.xz
+ b2sums = 88183f38f8fb7a97fb9870a8b742bdfbe648cc8a2ad9cfa785f2438e6376236608c544fb2887255153f05f4c30b55b374dfa3a237400768d8a34589a4fe30714
+pkgname = python-hipack
diff --git a/PKGBUILD b/PKGBUILD
index 700d7b8122d1..e981c07dbea9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,23 @@
# Maintainer: Adrián Pérez de Castro <aperez@igalia.com>
pkgdesc='Python module for the HiPack serialization format'
-pkgname=('python2-hipack' 'python-hipack')
-pkgbase='python-hipack'
-_pkgname='hipack'
-pkgver='12'
-pkgrel='1'
+pkgname=python-hipack
+_pkgname=hipack
+pkgver=14
+pkgrel=1
url='http://hipack.org'
-depends=()
-makedepends=('python2-setuptools' 'python-setuptools')
-license=('GPL3' 'MIT')
-arch=('any')
-source=("https://pypi.python.org/packages/source/h/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-sha512sums=('958c85dd852bd36fe2bd21c5d24f67eb2276130fabd624afcc4264b522ce49b7955afc41dbdb666553fc9d9b5c5c5b14a821aece6c2c275d3aca86dfe031681b')
+depends=(python)
+makedepends=(python-build python-installer python-setuptools python-wheel)
+license=(GPL-3.0-only MIT)
+arch=(any)
+source=("https://github.com/aperezdc/hipack-python/releases/download/v${pkgver}/${_pkgname}-${pkgver}.tar.xz")
+b2sums=('88183f38f8fb7a97fb9870a8b742bdfbe648cc8a2ad9cfa785f2438e6376236608c544fb2887255153f05f4c30b55b374dfa3a237400768d8a34589a4fe30714')
-package_common () {
- python$1 setup.py install --optimize=1 --root="${pkgdir}"
- mv "${pkgdir}/usr/bin"/hipack{,$1}
-}
-
-package_python-hipack () {
- depends+=('python')
+build () {
cd "${_pkgname}-${pkgver}"
- package_common 3
+ python -m build --wheel --no-isolation
}
-package_python2-hipack () {
- depends+=('python2')
+package () {
cd "${_pkgname}-${pkgver}"
- package_common 2
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}