summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrián Pérez de Castro2015-09-19 10:20:10 +0200
committerAdrián Pérez de Castro2015-09-19 10:21:09 +0200
commita47b9b2b7b1c95f08018671526ad435b30065ca6 (patch)
tree221df45828cd77c6a51bf08f4143805817475cf2
downloadaur-a47b9b2b7b1c95f08018671526ad435b30065ca6.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD31
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ace2b0c2214
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v7
+# Sat Sep 19 08:21:02 UTC 2015
+pkgbase = python-hipack
+ pkgdesc = Python module for the HiPack serialization format
+ pkgver = 9
+ pkgrel = 1
+ url = http://hipack.org
+ arch = any
+ license = GPL3
+ license = MIT
+ makedepends = python2-setuptools
+ makedepends = python-setuptools
+ source = https://pypi.python.org/packages/source/h/hipack/hipack-9.tar.gz
+ md5sums = 52d43cc25382d75496799f86c6a6d2da
+
+pkgname = python2-hipack
+ depends =
+ depends = python2
+
+pkgname = python-hipack
+ depends =
+ depends = python
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8add663faa94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Adrián Pérez de Castro <aperez@igalia.com>
+pkgdesc='Python module for the HiPack serialization format'
+pkgname=('python2-hipack' 'python-hipack')
+pkgbase='python-hipack'
+_pkgname='hipack'
+pkgver='9'
+pkgrel='1'
+url='http://hipack.org'
+depends=()
+makedepends=('python2-setuptools' 'python-setuptools')
+license=('GPL3' 'MIT')
+arch='any'
+source=("https://pypi.python.org/packages/source/h/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+md5sums=('52d43cc25382d75496799f86c6a6d2da')
+
+package_common () {
+ python$1 setup.py install --optimize=1 --root="${pkgdir}"
+ mv "${pkgdir}/usr/bin"/hipack{,$1}
+}
+
+package_python-hipack () {
+ depends+=('python')
+ cd "${_pkgname}-${pkgver}"
+ package_common 3
+}
+
+package_python2-hipack () {
+ depends+=('python2')
+ cd "${_pkgname}-${pkgver}"
+ package_common 2
+}