summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStorm Dragon2020-04-02 12:27:25 -0400
committerStorm Dragon2020-04-02 12:27:25 -0400
commitcf093a0e037865e3d80060c9b88c7e9c554cc39d (patch)
tree49ee5c3c13512cfaf3b26bf316d7e15e079247db
parentede9c2c0df0dc18c8029949bc180550071a7f431 (diff)
downloadaur-cf093a0e037865e3d80060c9b88c7e9c554cc39d.tar.gz
Removed the python2 version since python2 is deprecated.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
2 files changed, 3 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06c30a97287e..68de7c2db056 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,13 +6,8 @@ pkgbase = python-hkdf
arch = any
license = BSD
makedepends = python-setuptools
- makedepends = python2-setuptools
source = https://pypi.python.org/packages/c3/be/327e072850db181ce56afd51e26ec7aa5659b18466c709fa5ea2548c935f/hkdf-0.0.3.tar.gz
sha256sums = 622a31c634bc185581530a4b44ffb731ed208acf4614f9c795bdd70e77991dca
pkgname = python-hkdf
- depends = python
-
-pkgname = python2-hkdf
- depends = python2
diff --git a/PKGBUILD b/PKGBUILD
index 589f5f435f89..cf0f664e29df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,24 @@
# Maintainer: Storm Dragon <stormdragon2976@gmail.com>
# Co-Maintainer: Maxime "pep" Buquet <archlinux@bouah.net>
-pkgname=('python-hkdf' 'python2-hkdf')
+pkgname='python-hkdf'
pkgver=0.0.3
pkgrel=4
pkgdesc="This module implements the HMAC Key Derivation function, defined at http://tools.ietf.org/html/draft-krawczyk-hkdf-01"
arch=('any')
url="https://pypi.python.org/packages/c3/be/hkdf-${pkgver}"
license=('BSD')
-makedepends=('python-setuptools' 'python2-setuptools')
+makedepends=('python-setuptools')
source=("https://pypi.python.org/packages/c3/be/327e072850db181ce56afd51e26ec7aa5659b18466c709fa5ea2548c935f/hkdf-${pkgver}.tar.gz")
build() {
cd "${srcdir}/${pkgname#python-}-${pkgver}"
python setup.py build
- python2 setup.py build
}
-package_python-hkdf() {
- depends=('python')
+package() {
cd "${srcdir}/${pkgname#python-}-${pkgver}"
python setup.py install --root="${pkgdir}/" --optimize=1
}
-package_python2-hkdf() {
- depends=('python2')
- cd "${srcdir}/${pkgname#python2-}-${pkgver}"
- python2 setup.py install --root="${pkgdir}/" --optimize=1
-}
-
sha256sums=('622a31c634bc185581530a4b44ffb731ed208acf4614f9c795bdd70e77991dca')