summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStorm Dragon2018-12-12 16:18:55 -0500
committerStorm Dragon2018-12-12 16:18:55 -0500
commitfb6e60f463d4c3d651f65da9fc7ac1b3de7c7fa7 (patch)
tree1de3aeb3822b17953652e99f506e7bfeb2cd434c
parent9a50b9cb686a9d57349401d49269feb111094d13 (diff)
downloadaur-fb6e60f463d4c3d651f65da9fc7ac1b3de7c7fa7.tar.gz
Fixed build function.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f2aa1a8b458..7d79535648e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Wed Dec 12 21:18:46 UTC 2018
pkgbase = python-hkdf
pkgdesc = This module implements the HMAC Key Derivation function, defined at http://tools.ietf.org/html/draft-krawczyk-hkdf-01
pkgver = 0.0.3
- pkgrel = 2
+ pkgrel = 3
url = https://pypi.python.org/packages/c3/be/hkdf-0.0.3
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 16161c1e86ee..e3df09ecd4f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=('python-hkdf' 'python2-hkdf')
pkgver=0.0.3
-pkgrel=2
+pkgrel=3
pkgdesc="This module implements the HMAC Key Derivation function, defined at http://tools.ietf.org/html/draft-krawczyk-hkdf-01"
arch=('any')
url="https://pypi.python.org/packages/c3/be/hkdf-${pkgver}"
@@ -11,14 +11,10 @@ license=('BSD')
makedepends=('python-setuptools' 'python2-setuptools')
source=("https://pypi.python.org/packages/c3/be/327e072850db181ce56afd51e26ec7aa5659b18466c709fa5ea2548c935f/hkdf-${pkgver}.tar.gz")
-build_python-hkdf() {
+build() {
cd "${srcdir}/${pkgname#python-}-${pkgver}"
python setup.py build
-}
-
-build_python2-hkdf() {
- cd "${srcdir}/${pkgname#python2-}-${pkgver}"
- python setup.py build
+ python2 setup.py build
}
package_python-hkdf() {