summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCellebyte2018-09-19 11:45:36 +0200
committerCellebyte2018-09-19 11:45:36 +0200
commitd61ceae5e2508144168265ba26c116ad13b9dfb3 (patch)
tree41a25427f7ca28d7ea207e224c7e5f4997a18a68
downloadaur-d61ceae5e2508144168265ba26c116ad13b9dfb3.tar.gz
Added initial PKGBUILD
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..990d98c63dfc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-hkp4py-git
+ pkgdesc = A Library for the hkp|hkps protocol on gpg|pgp keyservers.
+ pkgver = r5.7ea59dc
+ pkgrel = 1
+ url = https://github.com/Selfnet/hkp4py/
+ arch = any
+ license = MIT
+ depends = python-requests
+ source = git+https://github.com/Selfnet/hkp4py.git
+ sha512sums = SKIP
+
+pkgname = python-hkp4py-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e1e42a3a3c2f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=python-hkp4py-git
+pkgver=r5.7ea59dc
+pkgrel=1
+pkgdesc="A Library for the hkp|hkps protocol on gpg|pgp keyservers."
+url="https://github.com/Selfnet/hkp4py/"
+license=('MIT')
+arch=('any')
+depends=('python-requests')
+source=("git+https://github.com/Selfnet/hkp4py.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir"/hkp4py
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir"/hkp4py
+ python3 setup.py build
+}
+
+package() {
+ cd "$srcdir"/hkp4py
+ python3 setup.py install --root="$pkgdir" --optimize=1
+}